16

Whenever I connect my Samsung Galaxy S2 phone (running Android 4.0) via USB using an MTP connection one of two messages always pops up, either:

Unable to mount Android: Error initialising camera: -60: Could not lock the device

Error initialising camera: -60: Could not lock the device

or: Unable to mount Android: Error initialising camera: -53: Could not claim the USB device

Error initialising camera: -53: Could not claim the USB device

The phone however does mount successfully and I can add and delete files etc. I would just like to understand what the error message means, googling only seems to bring up descriptions of people mounting digital cameras and this doesn't seem relevant for a mobile phone.

5
  • I thought MTp didn't work on CM9, works fine in MIUI and Samsung Stock ROMs. – Uri Herrera Apr 28 '12 at 7:08
  • @UriHerrera I found it the other way round, MTP works fine with CM9 but not with stock – coversnail Apr 28 '12 at 7:10
  • Before going too far with this. I suggest you create a new user (I'll call it newuser here) Logon as newuser and try connecting your MTP device. As "myself" I get that same error, as newuser , it works. I think something happened in the past copying $HOME around from one install to another. The 'file' .gvfs gets messes up, but it seems to be more than that. – user268330 Apr 12 '14 at 21:52
  • Might there be a virtual machine running, by any chance? I got this error too when running Windows 7 as guest. The Win7 guest was somehow grabbing the camera before Ubuntu did and thus foiling up the permissions. After I disconnected the camera from Windows things proceeded normally in Linux. – user283067 May 19 '14 at 7:46
  • @MarisanoJames I started to get the second error message after I upgraded to Ubuntu 14.04. I did not get any error messages in Ubuntu 12.04. I always had Win 7 in virtual machine. – Uttam Pal Oct 4 '14 at 19:50
3

I found that when I was plugged into a usb 3.0 port I got the following messages:

usbfs: USBDEVFS_CONTROL failed cmd gvfs-gphoto2-vo rqt 33 rq 102 len 0 ret -71

But when I plugged into a usb 2.0 port it worked.

1
2

Try this : http://www.tuxtrix.com/2011/07/how-to-access-samsung-galaxy-s-ii-usb.html . It worked for me

Note : In Android 4.0 with TW launcher, you need to click on "more" to get the option.

1
  • 1
    Thanks for putting the effort in to answer. I know how to connect the phone with mass storage, my question was related to why does the error message appear and what does it when connecting via MTP – coversnail May 17 '12 at 6:56
0

I get this as well, but to be honest it's a bug and there's not much to question about it - but instead report it. Should not happen.

Not the answer you're looking for? Browse other questions tagged or ask your own question.