Yesterday, I have upgraded Ubuntu from 11.10 to 12.04 LTS and everything was ok (there was no error)

After restart, my "Auto Ethernet" connection established, also my VPN connection established.
And some pages loaded on firefox
-- I had a proxy app on my Ubuntu 11.10 (A java app) and after first restart, in 12.04 proxy connection was Ok and I was able to reach any web via firefox with proxy. after switching to chromium with no proxy, there is an error. (also, I have no Internet access any where, in any other application without proxy!)

So, I found that I can access web pages and services using IP Addresses but DNS not working. Because of my VPN server, I have to set METHOD to Automatic, so I can not use other DNS servers.

what is wrong with my Ubuntu? how can I fix it?

  • Experiencing the same problem. DNS look-ups are not working after upgrading from 11.10 to 12.04. – SabreWolfy Apr 29 '12 at 10:33
  • It isn't really possible to debug this without a lot more information about the affected machine. I suggest you open a bug report against resolvconf (using apport-bug) so that we can approach the problem more systematically. – jdthood Oct 30 '12 at 8:36

This problem has arised for me after using Cisco AnyConnect VPN Client. For some reason the file contained information of the network I was VPN'ing into. I simply removed the file and everything worked for me.

| improve this answer | |

May not work for everyone, but I solved this in 12.04 by going to "Edit Connections"(right click on your internet connection logo) and unticking the "Require IPv4 for this connection to complete" box. Instant result!

| improve this answer | |

This has to do with the switch to resolvconf for /etc/resolv.conf management, as described here.

I solved the problem by inserting dns-nameserver and dns-search options into /etc/network/interfaces. I obtained the values required from /etc/resolvconf/resolv.conf.d/original.

I don't know if this is the "best" or "proper" solution, but it resolved (!) the issue for me. I also don't know why this was necessary.

| improve this answer | |

Same problem here. I do not use Network Manager, so that may have had something to do with the problems during the upgrade. In looking at the article referenced above (http://www.stgraber.org/2012/02/24/dns-in-ubuntu-12-04/), it describes several files that could be present in /etc/resolvconf/resolv.conf.d . The file called "tail", which gets processed last by resolvconf, was not present, but "original" was. I simply copied the contents of "original" (containing my working DNS config) to the "tail" file, which I had created. As the user above, I am uncertain of the appropriateness of this solution, but it did resolve my problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.