2

After upgrading from 18.04 to 20.04, suspend crashes during the suspend request, or, crashes on resume. This is a desktop not a laptop. It is the same bios and hardware as 18.04.

20.04 crashes several different ways.

  • on suspend, usb turns off, fans and system LEDs stay on, screen goes blank, crash.
  • on suspend, screen flashes random colors & characters, fans & usb stay on, crash.
  • on resume, usb & fans turn on, after a few seconds usb turns off, black screen has grayed out login prompt, crash.

Suspending from the power icon or from the command line always crashes with fans running. Letting the machine suspend on timeout, always crashes on resume. Obviously 20.04 does not work with this hardware but why did 18.04 handle it?

To get out of the corrupted state I hold the power button down for 10 seconds. The reset button sometimes works, sometimes won't. This is a very hard crash.

  • Cpu: Ryzen 3600
  • Mobo: Gigabyte B450M-DS3H
  • Bios Version: F50
user@desk:~$ free -h 
              total        used        free      shared  buff/cache   available
Mem:           15Gi       1.3Gi        13Gi       150Mi       1.3Gi        13Gi
Swap:         2.0Gi          0B       2.0Gi

user@desk:~$ sysctl vm.swappiness
vm.swappiness = 60

user@desk:~$ ls -al ~/.local/share/gnome-shell/extensions
total 12
drwxrwxr-x 3 user user 4096 May 23  2019 .
drwx------ 3 user user 4096 Aug 14 10:51 ..
drwxrwxr-x 4 user user 4096 May 23  2019 clock-override@gnomeshell.kryogenix.org

user@desk:~$ ls -al /usr/share/gnome-shell/extensions
total 24
drwxr-xr-x 6 root root 4096 Aug 11 16:36 .
drwxr-xr-x 7 root root 4096 Aug 11 16:38 ..
drwxr-xr-x 2 root root 4096 Aug 11 16:36 desktop-icons@csoriano
drwxr-xr-x 2 root root 4096 Aug 11 16:38 openweather-extension@jenslody.de
drwxr-xr-x 3 root root 4096 Aug 11 16:31 ubuntu-appindicators@ubuntu.com
drwxr-xr-x 3 root root 4096 Aug 11 16:32 ubuntu-dock@ubuntu.com

8
  • Edit your question and show me sudo dmidecode -s bios-version and tell me your make/model # of your computer or motherboard, and free -h and sysctl vm.swappiness and ls -al ~/.local/share/gnome-shell/extensions and ls -al /usr/share/gnome-shell/extensions. Start comments to me with @heynnema or I'll miss them.
    – heynnema
    Aug 13 '20 at 21:57
  • @heynnema I added the requested info.
    – miarbor
    Aug 14 '20 at 15:35
  • Edit your question and show me sudo lshw -C memory, and tell me what video card you have, and what driver version.
    – heynnema
    Aug 14 '20 at 15:52
  • Status please...
    – heynnema
    Aug 19 '20 at 2:37
  • @heynnema The hardware successfully passed the google stressapptest. I tried Kubuntu 20.04 but like Ubuntu 20.04 suspend failed. I installed a mothballed HDD with Ubuntu 18.04 from May of 2019 and it successfully suspended (kernel 4.15.0-50). Using the Software Updater I updated the HDD to Ubuntu 18.04.5 LTS (kernel 4.15.0-112.113-generic 4.15.18). 18.04.5 successfully suspends. Whatever failed in the 20.04 upgrade is resolved in 18.04.5. I will abandon 20.04 and consider the problem fixed.
    – miarbor
    Aug 26 '20 at 22:05
0

overclocked

If your CPU or RAM are overclocked, please return them to default.

drwxrwxr-x 4 user user 4096 May 23  2019 clock-override@gnomeshell.kryogenix.org

BIOS

Gigabyte B450M-DS3H

You have BIOS version F50.

There's a newer BIOS available, version F51, and can be downloaded here

enter image description here

Note: Make sure that I have the correct web page for your model #.

Note: Have good backups before updating the BIOS.

swap

Let's create a slightly larger /swapfile...

Confirm this line in /etc/fstab...

Note: Assure that there are no other lines containing "swap".

/swapfile    none    swap    sw      0   0

Note: Incorrect use of the dd command can cause data loss. Suggest copy/paste.

sudo swapoff -a           # turn off swap
sudo rm -i /swapfile      # remove old /swapfile

sudo dd if=/dev/zero of=/swapfile bs=1M count=4096

sudo chmod 600 /swapfile  # set proper file protections
sudo mkswap /swapfile     # init /swapfile
sudo swapon /swapfile     # turn on swap
free -h                   # confirm 16G RAM and 4G swap
reboot                    # reboot and verify operation

memory

Ryzen processors are notorious for memory compatibility problems.

Edit your question and show me sudo lshw -C memory.

Go to https://www.memtest86.com/ and download/run their free memtest to test your memory. Get at least one complete pass of all the 4/4 tests to confirm good memory. This may take many hours to complete.

CPU Support List: https://www.gigabyte.com/Motherboard/B450M-DS3H-rev-10/support#support-cpu

Memory Support List: https://www.gigabyte.com/Motherboard/B450M-DS3H-rev-10/support#support-doc

0

Fixed for the time being. I appended nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub

Now the box successfully suspends and is noticeably faster too. I made no hardware or bios changes.

nomodeset appears to have given 20.04's memory footprint the time it needs to become stable.

I will keep this box under observation in case other anomalies pop up.

1
  • For a system running Ubuntu 20.04 and a NVIDIA KM2100 inside nomodeset is freezing the boot process and also an external display is not used anymore.
    – k_o_
    Dec 7 '20 at 22:18
0

I had the same problem and I tried as miarbor suggested to add nomodeset to the grub, unfortunately with NVIDA graphic card, this screw-up the visualization of the whole system! I solved it rather by using the original NVIDA binary driver (proprietary, tested) not the open source X.OrgXserver recomended by Ubuntu developer! see pictureNVIDA graphic card

0

I also faced similar issue on Ubuntu 20.04. I checked the log File and found that there was some issue with ACPI.

I was able to resolve it by typing the following in Terminal:
echo "disable" > /sys/firmware/acpi/interrupts/gpe6F

Found this answer here: http://jhshi.me/2015/11/14/acpi-error-method-parseexecution-failed-_gpe_l6f/index.html#.YHhsW4Mzbm4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.