I recently installed Ubuntu 20.04 and also, on a separate machine, moved from Linux Mint 19.3 to 20, with the move from Ubuntu 18.04 to 20.04 underlying it.

I use a Canon MG5750 printer/scanner/copier, which works fine in all respects, wirelessly, with LM19.3. The printer was picked up automatically, no installation of additional drivers was necessary.

Under LM20 and also with Ubuntu 20.4 however, duplex (two-sided) printing will not work. The first sheet is drawn back into the printer as is usual in order to print on the other side, but then passed out blank, and the second page is printed on a new sheet, and so on. The printer is also picked up automatically in these new releases and printing works fine in all other respects.

I have reverted back to LM19.3 as my working set up as a result.

Printer test pages show that under LM19.3 the driver version is 1.20.2, whereas under LM20 and Ubuntu 20.4 it is version 1.27.4.

Any comments or suggestions would be welcome - but I feel that if it worked before automatically, but doesn't in the new release, there is an error somewhere in the new release.

  • Sometimes features that aren't standardized rely on software for the feature to work. A good example of this is the "scan to file" button on many printers. Perhaps this is the case for your device? Unfortunately a lot of manufacturers only consider writing the software for Windows, but if you can explore whether or not the software is required in Windows, that may answer the question of whether or not the feature would be supported without software in Ubuntu/Linux
    – Nmath
    Aug 14, 2020 at 5:38
  • I have the same problem since I moved to Ubuntu 20.04 with another Canon printer (Pixma TS6150). It used to work perfectly. @daisy42 did you find a solution to this ? I tried reinstalling up-to-date drivers but it didn't solve anything either and stopped investigating thinking that the problem will be solved by more experienced users than me...
    – raph
    Oct 7, 2020 at 9:25

1 Answer 1


Eventually the following appeared on the Mint Forum. I implemented it and it worked in terms of restoring automatic two-sided printing - but I subsequently found that the multiple copies function doesn't work! So not exactly a complete solution. The procedure was to copy the PPD from 19.3, insert it into 20 and associate the printer with it, as follows:

copy the ppd file (/etc/cups/ppd) from Mint 19.3 to a disk accessible by Mint 20.

  • Boot up Mint 20, power on the printer.
  • Bring up the browser and in the search bar enter localhost:631
  • That brings up the cups interface. then:
  • click Administration
  • click Manage Printers and click on your printer
  • click Modify Printer
  • when prompted enter your Linux userid and password
  • Under Discovered Printers click on your printer (driverless)
  • click Continue
  • enter a description, etc if desired
  • click Continue
  • at the bottom of page by Provide PPD File browse to your Mint 19.3 ppd file
  • click Modify Printer

DONE! Connects wirelessly, works as well as in Mint 19.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.