0

I'm running Ubuntu 20.04 with the 5.4.0-42-generic kernel.

I have an external WD Elements USB 3.0 2TB drive attached.

Recently, while copying ~35GB of audio files from this drive to my Pixel 2 XL phone (connected with a USB 3.0 cable to a USB 3.0 USB port on the computer), I noticed that the transfer speed starts at ~ 20MB/sec, and after a while, the speed is down near 2MB/sec, which makes the transfer time hours long.

It seems that the usb-storage driver needs to be loaded instead of UAS (which apparently is the cause of the bottleneck).

I read an article on how to blacklist the UAS driver in the kernel, which did not work. It seems that the article was referring to drivers that are loaded as modules, but I think maybe the UAS driver is built into this kernel and therefore NOT loaded as a module, so the suggested procedure did not work. I am not interested in compiling/using a different kernel.

Can someone comment on how to blacklist a UAS driver that is built into a kernel and then enable the usb-storage driver instead?

TIA for any help provided.

1

First identify exactly the module you want to blacklist, at a terminal type

lsmod | head -20

Then you can note extra information by typing

modinfo modulename

modulename being the name you found previously with lsmod
Then add this modulename to the config file by typing

sudo nano /etc/modprobe.d/blacklist.conf

(Or you can use gedit or vi instead of nano)
Add a line to the bottom of this file that reads

blacklist modulename


modulename being the name you found previously with lsmod
Commit the changes and save with the same filename then reboot.

3
  • Thanks, darth_epoxy. I found both a uas and a usb_storage module reported by lsmod.
    – delta1071
    Aug 13 '20 at 16:15
  • To the above response, I forgot to add that the usb_storage and uas modules were both loading at boot. After adding the uas driver to the blacklist and running modprobe again, only the usb_storage driver is loaded. I tried some file transfers from the external drive to my phone. The transfer speed is about 10MB/sec, which is an improvement but far less than what I would expect (the USB drive is advertised as capable of ~100MB/sec, so I would expect somewhere near 50MB/sec.)
    – delta1071
    Aug 14 '20 at 7:23
  • OK then, accept this answer (grey icon on the LHS) as we have solved the blacklist question - and then post a new question i.e. How to increase speed of USB transfers using usb_storage driver/module? Aug 14 '20 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.