2

screenshot added for clarityI've just upgraded from 18.04 to 20.04 and use gnome flashback(metacity) as my desktop. Before I updated I had been able to remove the 'home' and 'rubbish bin' icons from my desktop, as I like the clean look. Today I have spent most of the afternoon trying to remove these annoying and unnecessary icons from my desktop!I would be very grateful if anyone could advise me as to how to do it!

Thanks

edited to show result of comment 12/08/20 @WU_TANG I tried gsettings set org.nnemo.desktop show-desktop-icons false as can be seen below -- no result!

    (base) matt@zakk-jr:~$ gsettings list-recursively | grep icons
org.nemo.icon-view labels-beside-icons false
org.gnome.gnome-flashback.desktop show-icons false
org.cinnamon.desktop.interface menus-have-icons true
org.cinnamon.desktop.interface buttons-have-icons false
org.cinnamon.desktop.interface toolbar-icons-size 'large'
org.gnome.gnome-flashback.desktop.icons icon-size '48px'
org.gnome.gnome-flashback.desktop.icons column-spacing uint32 10
org.gnome.gnome-flashback.desktop.icons show-home false
org.gnome.gnome-flashback.desktop.icons sort-by 'name'
org.gnome.gnome-flashback.desktop.icons show-trash false
org.gnome.gnome-flashback.desktop.icons placement 'auto-arrange-icons'
org.gnome.gnome-flashback.desktop.icons row-spacing uint32 2
org.gnome.gnome-flashback.desktop.icons extra-text-width uint32 48
org.gnome.shell.extensions.openweather use-symbolic-icons true
org.gnome.shell.extensions.topicons icon-size 24
org.gnome.shell.extensions.topicons icon-saturation 0.40000000000000002
org.gnome.shell.extensions.topicons tray-pos 'center'
org.gnome.shell.extensions.topicons icon-contrast 0.0
org.gnome.shell.extensions.topicons icon-spacing 12
org.gnome.shell.extensions.topicons tray-order 1
org.gnome.shell.extensions.topicons icon-brightness 0.0
org.gnome.shell.extensions.topicons icon-opacity 220
org.gnome.desktop.background show-desktop-icons false
org.gnome.desktop.interface menus-have-icons false
org.gnome.desktop.interface buttons-have-icons false
org.gnome.desktop.interface toolbar-icons-size 'large'
org.gnome.shell.extensions.desktop-icons show-trash false
org.gnome.shell.extensions.desktop-icons icon-size 'standard'
org.gnome.shell.extensions.desktop-icons show-home false
org.nemo.desktop show-desktop-icons false
org.nemo.desktop show-orphaned-desktop-icons false
org.gnome.gnome-panel.general prefer-symbolic-icons false

Further edit to add information: I set up another user on this machine, and when I ran ' gsettings set org.gnome.gnome-flashback.desktop show-icons false' the icons disappeared, so now i'm really confused!!

further edit to show dconf-editor settings : enter image description here

output of xprop as requested:

    (base) matt@zakk-jr:~$ xprop
    WM_STATE(WM_STATE):
    window state: Normal
    icon window: 0x0
    _NET_WM_DESKTOP(CARDINAL) = 4294967295
    _NET_WM_STATE(ATOM) = _NET_WM_STATE_SKIP_PAGER, 
    _NET_WM_STATE_SKIP_TASKBAR, _NET_WM_STATE_STICKY
    _NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_CHANGE_DESKTOP, 
    _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW
     WM_HINTS(WM_HINTS):
    Client accepts input or input focus: True
    Initial state is Normal State.
    window id # of group leader: 0x1000001
    _GTK_THEME_VARIANT(UTF8_STRING) = "dark"
    XdndAware(ATOM) = BITMAP
    _NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_DESKTOP
    _NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 16777221, 16777222
    _NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x1000004
    WM_CLIENT_LEADER(WINDOW): window id # 0x1000001
    _NET_WM_PID(CARDINAL) = 2431
    WM_LOCALE_NAME(STRING) = "en_GB.UTF-8"
    WM_CLIENT_MACHINE(STRING) = "zakk-jr"
    WM_NORMAL_HINTS(WM_SIZE_HINTS):
    program specified minimum size: 3286 by 1080
    program specified base size: 0 by 0
    window gravity: NorthWest
    WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, 
    _NET_WM_PING, _NET_WM_SYNC_REQUEST
    WM_CLASS(STRING) = "gnome-flashback", "Gnome-flashback"
    WM_ICON_NAME(STRING) = "Desktop"
    _NET_WM_ICON_NAME(UTF8_STRING) = "Desktop"
    WM_NAME(STRING) = "Desktop"
   _NET_WM_NAME(UTF8_STRING) = "Desktop"
   (base) matt@zakk-jr:~$ 
3
  • Interesting... Desktop icons are from gnome-flashback, but if you have disabled them with gsettings set org.gnome.gnome-flashback.desktop show-icons false icons should not be on desktop! Can you restart gnome-flashback from terminal? gnome-flashback --replace. Does it output something in terminal? – muktupavels Aug 28 '20 at 10:56
  • 1
    Perhaps (base) in your terminal has something to do with your problem? From quick search it is from conda... Can you deactivate it conda deactivate? Then try again to disable desktop icons with gsettings set org.gnome.gnome-flashback.desktop show-icons false. – muktupavels Aug 28 '20 at 11:05
  • that worked!! I now have no icons, Many Thanks – matt cooper Aug 28 '20 at 11:38
2

In a terminal remove all the icons on the desktop with:

gsettings set org.gnome.gnome-flashback.desktop show-icons false

Or with Nemo:

gsettings set org.nemo.desktop show-desktop-icons false
7
  • This should work if you don't want icons at all. Otherwise you can use gsettings set org.gnome.gnome-flashback.desktop.icons show-home false and gsettings set org.gnome.gnome-flashback.desktop.icons show-trash false. – muktupavels Aug 12 '20 at 18:02
  • @WU-TANG i've tried these commands with no success, the icons are gome if i use the GNOME (Unity) environment, but are there in GNOME flashback(compiz) and (metacity), I've added the the result of gsettings list-recursively org.gnome.gnome-flashback as a screenshot in the original question – matt cooper Aug 14 '20 at 11:02
  • I use 20.04 and flashback-metacity myself... this exact command removes them on my system... You are not trying to do them as root or sudo???? – WU-TANG Aug 14 '20 at 14:48
  • @WU-TANG no, i'm not doing it as root or sudo, as you can see from the screenshot in the op. I also cannot move the icons, nemo is installed, not nautilus (if that helps). I'm completely confused by this!! – matt cooper Aug 14 '20 at 16:23
  • Then you probably should be more widely searching for your environment.... gsettings list-recursively | grep icons will yield more options. Answer updated – WU-TANG Aug 14 '20 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.