2

thanks for taking time to read me.

I was looking for a way to use fully my GC in blender (openCL etc.), I'm new to linux.

So I checked and my GC, which is Radeon HD 7870 GHz edition, is compatible with amdgpu drivers

 lspci -k | grep -EA3 'VGA|3D|Display'
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]
        Subsystem: PC Partner Limited / Sapphire Technology Pitcairn XT [Radeon HD 7870 GHz Edition]
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu

but, as you can see here, it's not used by default and I don't know why.

*-display                 
       description: VGA compatible controller
       produit: Pitcairn XT [Radeon HD 7870 GHz Edition]
       fabricant: Advanced Micro Devices, Inc. [AMD/ATI]
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       version: 00
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration : driver=radeon latency=0
       ressources : irq:30 mémoire:e0000000-efffffff mémoire:f7e00000-f7e3ffff portE/S:e000(taille=256) mémoire:c0000-dffff

I looked for solution, and I tried several things :

  • blacklist radeon -> not working
  • installing amdgpu and telling grub to boot with it -> lead to black screen on boot (no signal)
  • installing amdgpu-pro and telling grub to boot with it -> lead to black screen on boot (no signal)

so here I am, I tried other thing that I don't remember but nothing works.

1

Old question, I know, but it was my first Google hit when searching for this. So I'll leave what worked for me (Also Ubuntu 20.04 + Radeon HD 7870 GHz):

Add PPA:

$ sudo add-apt-repository ppa:oibaf/graphics-drivers
$ sudo apt update && sudo apt upgrade

Then edit Grub: sudo gedit /etc/default/grub and add the following lines to the end:

GRUB_GFXMODE=1920x1080x32
GRUB_CMDLINE_LINUX_DEFAULT="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1 amdgpu.modeset=1"

Finally, update Grub and reboot:

$ sudo update-grub2 && sudo update-initramfs -u -k all
$ reboot

Confirm with lspci -k | grep -EA3 'VGA|3D|Display'.

Blacklisting radeon was not neccessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.