13

Does anyone use an XP-PEN Deco 01 V2 with Ubuntu 20.04 LTS? I'd like to buy this device but before I'd like to know if it works well with Ubuntu 20.04. I saw that drivers for linux exist (https://www.xp-pen.com/download-440.html). But do you know if they work well?

Thank you for your support.

3 Answers 3

5

Yes, I bought it couple of days back and using it in ubuntu 20.04 LTS only. I have tried with Gimp and its working superb. Nothing installed any drivers. I have downloaded the drivers from the product URL but didn't install it. It detected automatically.

2
  • Do you mind confirming whether or not V2 features like the tablet rotatation, backlight, and stylus tilt functionality work?
    – anjama
    Nov 8, 2020 at 18:59
  • I haven't tried tilt and other functions. Tablet roation and other stuffs you prob you need to download the drivers from their site and need to configure it. But I used it like a normal mouse. I am able to modify the properties after installing the drivers but left button is not able to map it to any only right button and left or right hand mode thats it. nothing else. The backlight and all work when you connected to the system. the lights will automatically turned on. Nov 9, 2020 at 13:06
4

Browse to the following location on the xp-pen site and search for Deco 01 V2 https://www.xp-pen.com/download/index.html

Download the BETA driver XP-PEN_3.0.5.201126-1.x86_64(New UI Beta Driver)

Extract the downloaded file and open terminal staying within that folder and run sudo ./install.sh

This should install the application to your usr/lib/pentablet folder. Even though it successfully installs you might not be able to use it as there seems to be a bug in the installation.

But there is a work around. Navigate to your usr/lib/pentablet open terminal from within that folder and run the following sudo CHMOD +x ./pentablet

Once thats done. Navigate to usr/share/applications and open terminal from within that folder. In terminal type the following sudo gedit ./xppentablet.desktop

Change the following lines FROM Exec=/usr/lib/pentablet/pentablet.sh

TO Exec=/usr/lib/pentablet/pentablet

Save and exit.

You should now see your pentable application available in the launcher

0

I have tested it with the Xournal application (PDF annotation). Pressure sensitivity works well.

I did not install any drivers. Ubuntu 20.04 works with this graphics tablet out of the box :)

But I do not see any Wacom graphics tablet in Ubuntu settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .