1

I've installed Ubuntu 20 LTS from official site with Rufus. And then I downloaded Google Chrome from google.com/chrome 64 bit.deb for Ubuntu The first time I open, Chrome works nomally but after that time I can't manage to open it, I tried to launch it from terminal/gnome it yeilds: NaCl helper process running without a sandbox! Most likely you need to configure your SUID sandbox correctly This also happens on Ubuntu 18.04 Any help is appreciated!

  • Chrome works for me on all Ubuntu releases. You are doing something wrong. I hope you are not running it with sudo. – Pilot6 Aug 11 at 16:27
  • Chrome requires that you either add a PPA or manually install from a .deb package. Neither are good methods to install software especially if you are not intimately familiar with package management in Ubuntu. Have you tried to install and use Chromium instead? It's essentially Chrome before Google adds all of the dirty proprietary mess. Install w/: sudo apt update followed by sudo apt install chromium-browser – Nmath Aug 11 at 16:50
  • Read this : stackoverflow.com/questions/47269579/… – White Mars Aug 11 at 17:02
  • @Nmath yes, it works, chromium works on my machine. However, I still can't manage to make gg chrome work on my machine although I've tried many ways but every time I open gg chrome it say "NaCl..." – Phạm Văn Tiến Aug 12 at 15:12
0

you can use Chromium browser (the open-source version of Chrome) instead of Google Chrome.

  • You can run the command chromium-browser in terminal. Thank you.
| improve this answer | |
  • Has to install chromium first before using that command. Also not good answer for fixing chrome that the OP wants. – crip659 Aug 11 at 16:17
  • @crip659 Please check now. Thank you. – S J J Aug 11 at 16:23
  • Command 'chromium-browser' not found, but can be installed with: sudo apt install chromium-browser. Do have chrome installed. – crip659 Aug 11 at 16:37
  • @crip659 I agree with you. Regards. – S J J Aug 11 at 16:39
  • Please also check another answer. Thank you. – S J J Aug 11 at 16:40
0

please try these commands.

  • sudo apt update
  • sudo apt upgrade
  • wget --version (checks whether wget is installed or not), if wget not installed, use the command sudo apt install wget
  • wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
  • sudo dpkg -i google-chrome-stable_current_amd64.deb
  • For opening application via terminal, use google-chrome Thank you.

Attribution - https://linuxhint.com/ubuntu_20-04_google_chrome_installation_guide/

| improve this answer | |
  • I've tried your suggestion but it doesn't work. After installing and from terminal I google-chrome but it yeilds "NaCl helper process....Most likely ... SUID" – Phạm Văn Tiến Aug 12 at 15:05
  • @PhạmVănTiến, Hi, Try this command instead of the fifth above. sudo apt install ./google-chrome-stable_current_amd64.deb – S J J Aug 13 at 6:53
  • it does not work, still get NaCl... – Phạm Văn Tiến Aug 13 at 17:12
  • @PhạmVănTiến, Hi, you can use chromium instead of chrome. Thank you. – S J J Aug 14 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.