I've tried most of the solutions I've found so far still to no avail. I have a 29" widescreen Dell monitor running Ubuntu 18.04.4. First I went into display settings and attempted to switch to portrait mode, it logged me out, I logged back in, nothing changed. I tried landscape flipped and it worked just fine.

Next, I tried using various xrandr commands (see below)

xrandr commands

xrandr --output HDMI-1 --rotate right
xrandr -o right

If needed I can get any output log, I just don't know which one's you all may need to see. I think the weirdest part of the problem is that landscape works in both ways, but portrait doesn't work in either direction. Thanks in advance for any help :)

1 Answer 1


Found the solution linked from this question but I'll paste here for easy access.

It's apparently a better solution to run X11 as root. The one-line fix is to add this to this to /etc/X11/Xwrapper.config:

needs_root_rights = yes

It's a one line fix in /lib/systemd/system/gdm3.service






ExecStartPre=/usr/bin/xinit /usr/share/gdm/generate-config

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .