0

I am having this conflict:

The following packages have unmet dependencies:
 libncursesw5-dev : Depends: libtinfo5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is installed
                    Depends: libncursesw5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is installed
                    Depends: libtinfo-dev (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is installed

And I am baffled that apt does not realize these are the exact same version barring the distribution suffix. I tried aptitude and dpkg, they all report this issue.

Btw if somebody is wondering, I solved the conflict by downloading the deb and then running:

sudo dpkg --ignore-depends=libncursesw5,libtinfo-dev,libtinfo5:amd64 -i ./libncursesw5-dev_6.1-1ubuntu1_amd64.deb
2
  • 1
    The "distribution suffix" is part of the version string, so apt sees them as different versions: 6.1-1ubuntu1 vs 6.1-1ubuntu1.18.04. In this case, whatever you are installing requires a specific version, perhaps from a specific source, and substitutions with (an apparently) similar package from another source have not been tested and may not work. Glad it did happen to work in your case. I've seen others where it did not work. – user535733 Aug 10 '20 at 13:12
  • 1
    The package versions are not the same; the first is the initial 18.04 packaged version, the second has subsequent bug fixes (inc. CVE-2018-10754 fix) that wasn't in the original bionic packaged version - changelogs.ubuntu.com/changelogs/pool/main/n/ncurses/… packages.ubuntu.com/bionic-updates/libtinfo5 If you're not impacted by those CVEs, and don't need the patches that fix them... it's your choice. – guiverc Aug 10 '20 at 13:49
3

The package versions are not exactly the same

The first is the initial 18.04 packaged version, the second has subsequent bug fixes (inc. CVE-2018-10754 fix) that wasn't in the original bionic packaged version

see:

https://packages.ubuntu.com/bionic-updates/libtinfo5

https://changelogs.ubuntu.com/changelogs/pool/main/n/ncurses/ncurses_6.1-1ubuntu1.18.04/changelog

ncurses (6.1-1ubuntu1.18.04) bionic-proposed; urgency=medium

  * SRU: LP: #1772872: Backport changes from 6.1+20180210-4:   * Move screen.xterm-256color and rxvt-unicode-256color terminfo entries
    from ncurses-term to ncurses-base (Closes: #898666, #898948).   * Cherry-pick a fix from the 20180414 patchlevel: add a null-pointer
    check in _nc_parse_entry to handle an error when a use-name is invalid
    syntax (report by Chung-Yi Lin, CVE-2018-10754).

 -- Matthias Klose <doko@ubuntu.com>  Wed, 23 May 2018 10:08:27 +0200

I only looked up the first of your listed packages, I suspect you'll find the same for the others too

1
  • Maybe the package that has the depends rule clashes with the CVE-2018-10754 or other fix included in the updated package, OR maybe it was created before the bugs were detected and later fixed (and the dev was careful to package it only for the version it was tested to work with).. either way they are different packages.. – guiverc Aug 10 '20 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.