2

Symptoms: After upgrading a dual-boot system from 19.10 to 20.04LTS, mouse and keyboard don't work. No input from either device is recognised, so switching to a tty is not possible. Pressing CTRL-ALT-DEL causes instant reboot without the normal shutdown dialog. There had been no apparent problems prior to the upgrade.

Mouse and keyboard both work when booted into recovery at the GRUB menu (select Ubuntu 20.04.xx recovery -> select resume, then yes). Disabling autologin also results in correct mouse and keyboard operation. In both cases, CTRL-ALT-DEL causes normal shutdown dialog.

Hardware: Gigabyte Motherboard with AMD Ryzen 5 3600, 16GB RAM, Gigabyte RTX2060 graphics, Logitech M510 and K350 with a unifying receiver, and a gigabit network card.

Things I have tried so far:

  1. Re-install Ubuntu 20.04.1 from a USB disc image, but retaining home directory -> no difference, still broken
  2. Disable autologin -> mouse and keyboard work, but I'm a single user and I don't need nor want the login screen
  3. Install KDE -> keyboard and mouse work normally, even with autologin enabled
  4. Install LightDM -> same as for KDE
  5. Switch back to GNOME, reinstall NVIDIA drivers -> no difference, still broken
  6. Upgrade NVIDIA drivers to latest version from repo -> no difference, still broken
  7. Upgrade NVIDIA drivers from NVIDIA website -> no difference, still broken
  8. Revert to open source NVIDIA drivers -> Keyboard and mouse work, but opening GNOME-settings causes instant logout. System cannot be logged in without reboot.
  9. Adding NOMODESET to GRUB -> no difference, still broken.

I am basically out of options. I tried posting the issue as a bug on the GNOME bug tracker website, the response was an arrogant "not a GNOME issue", which it clearly is because GNOME is the only DM that has this problem.

Has anyone figured out what's causing this? I know I'm not the only one to run into it.

0

Have a similar issue using gdm. Try to temporarily boot GRUB with no X-Server/graphics running: press 'E' during boot choice and add 3 at the end of line linux /boot/vmlinux etc. after ro quiet splash

You should now be able to login using the console, if nothing shows up on screen press Ctrl+Alt+F1 and login.

Next, stop gdm: sudo systemctl stop gdm

You should get some output in the terminal. Next restart gdm: sudo systemctl start gdm

This should now bring up your desktop with mouse/keyboard working, worked for me.

| improve this answer | |
  • There are a couple of simpler workarounds: 1. Boot into recovery mode from the GRUB menu and select "resume" 2. Disable autologin in Settings -> Users. – Tony Kerr Aug 15 at 0:45
  • This works indeed, thanks for the tip! Much simpler. So the problem is autologin? Is that a problem many people are experiencing? Any ideas what the root cause is? – Philosophaster Aug 21 at 8:54
  • Not a clue. I've done some shell scripting and some microcontroller software in assembler and C, but a large system like this is beyond me. As I said, I think the problem is with GNOME, because the other desktop managers I have tried all work perfectly. The GNOME people aren't interested, however. – Tony Kerr Aug 25 at 13:09
0

I had the same problem, that comment helped me to fix it.:

@tony-kerr Upgrade to 20.04, mouse and keyboard don't work - any idea how I fix this?

There are a couple of simpler workarounds: 1. Boot into recovery mode from the GRUB menu and select "resume" 2. Disable autologin in Settings -> Users.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.