3

Is there a way to configure the current samba to be able to display workgroups and/or homegroups?

SMB1 disabled -- no workgroup available
10

First, there is no such thing as a HomeGroup in Linux, MacOS, or Windows starting with Win10.

Second, if you are talking about that specific error when running smbclient you would need to enable SMB1 ( Samba calls it NT1 ) on the client side in /etc/samba/smb.conf. Right under the workgroup = WORKGROUP line add this one:

client min protocol = NT1

Of course the server you are trying to connect to must have SMB1 enabled on its side. If you kept your Win10 machine up to date it is disabled so you will have to enable it there. If the server is running Ubuntu 20 or anything with the same version of samba you would have to edit smb.conf on that machine and add:

server min protocol = NT1

Then restart samba:

sudo service smbd restart
sudo service nmbd restart

If you don't do that on the server you will likely get a protocol negotiation failed: error.

That will probably eliminate the SMB1 error message. Whether you can "discover" all the workgroups and hosts in Nautilus is another matter. If you have to turn the clock back to SMB1 days you need to follow the rules set at that era ... name resolve order, host name length restrictions, etc ...

2
  • It'd be nice if that worked, but it doesn't. It doesn't complain about those options, but they don't actually do anything. min/max set to NT1, SMB2/3 are still the only things that work. – Ricky Apr 16 at 10:43
  • Frankly not being able to connect to existing but legacy appliances is a greater security concern than any SMB1 risk on most home networks. Ubuntu seem to have forgotten their roots. Only firmware should still be running it. Upgrading is not always economically possible, – mckenzm Apr 23 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.