0

There already are many of the same questions but they ALL seems to be about the default X11, because they are all using "Virtual1", which seems to be the monitor name in X11, which is different from "XWAYLAND0", which seems to be the default monitor name for Wayland.

I have tried methods like

Section "Monitor"
    Identifier "XWAYLAND0"
    Modeline "p1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    Option "PreferredMode" "p1920x1080"
EndSection

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet video=XWAYLAND0:1920x1080@60" 

or

xrandr --newmode "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode XWAYLAND01920x1080
xrandr --output XWAYLAND0--mode 1920x1080

But none of them worked for Wayland. The top one worked for X11, though. So, is there any way to get 1080p on "Ubuntu (Wayland)", or is it impossible?

0

What worked for me is skipping the monitor name.

In /etc/default/grub file,

GRUB_CMDLINE_LINUX_DEFAULT="quiet video=1920x1080-32"

Also setting below variables helps

GRUB_GFXMODE=1920x1080x32
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_TERMINAL=gfxterm

Then run command

sudo update-grub

For more info: https://www.systutorials.com/configuration-of-linux-kernel-video-mode/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.