2

My /var/log/syslog and var/log/kern.log fills up very fast ang It freezes my computer and even shutdown, restart don't work. My wifi stops working, and even If I restart network-service using terminal systemctl also doesn't work.

Here's the image related to my network-manager error. My network-manager problem is similar to this problem.

Both of the log files are filling with the same 10 lines of messeges.

Aug 10 04:29:35 kernel: [  471.710774]  worker_thread+0x4d/0x400
Aug 10 04:29:35 kernel: [  471.710776]  kthread+0x104/0x140
Aug 10 04:29:35 kernel: [  471.710778]  ? process_one_work+0x3b0/0x3b0
Aug 10 04:29:35 kernel: [  471.710780]  ? kthread_park+0x90/0x90
Aug 10 04:29:35 kernel: [  471.710782]  ret_from_fork+0x35/0x40
Aug 10 04:29:35 kernel: [  471.710784] ---[ end trace e68a032e184ce76a ]---
Aug 10 04:29:35 kernel: [  471.710803] ------------[ cut here ]------------
Aug 10 04:29:35 kernel: [  471.710804] wlp3s0:  Failed check-sdata-in-driver check, flags: 0x4
Aug 10 04:29:35 kernel: [  471.710834] WARNING: CPU: 2 PID: 8 at net/mac80211/driver-ops.h:17 drv_sta_state+0x254/0x3f0 [mac80211]
Aug 10 04:29:35 kernel: [  471.710835] Modules linked in: ccm rfcomm cmac algif_hash algif_skcipher af_alg bnep nls_iso8859_1 intel_rapl_msr intel_rapl_common x86_pkg_temp_thermal intel_powerclamp coretemp amdgpu mei_hdcp kvm snd_hda_codec_hdmi amd_iommu_v2 gpu_sched crct10dif_pclmul snd_hda_codec_conexant snd_hda_codec_generic ledtrig_audio ghash_clmulni_intel snd_hda_intel snd_intel_dspcfg snd_hda_codec snd_hda_core snd_hwdep snd_pcm aesni_intel crypto_simd snd_seq_midi cryptd glue_helper intel_cstate snd_seq_midi_event intel_rapl_perf uvcvideo snd_rawmidi iwlmvm videobuf2_vmalloc mac80211 videobuf2_memops libarc4 videobuf2_v4l2 rtsx_usb_ms btusb i915 videobuf2_common memstick snd_seq serio_raw btrtl radeon btbcm snd_seq_device iwlwifi btintel ttm input_leds videodev bluetooth mc joydev snd_timer drm_kms_helper ecdh_generic ecc i2c_algo_bit fb_sys_fops ideapad_laptop cfg80211 syscopyarea snd sysfillrect mei_me sparse_keymap mei sysimgblt soundcore wmi mac_hid acpi_pad sch_fq_codel parport_pc ppdev lp parport drm

I didn't have this problem in previous versions of Ubuntu. It started when I upgrade to 20.04 LTS. Even I've reinstalled Ubuntu and even I tried upgrading my kernel, but It didn't help. Even using amdgpu instead of radeon didn't help. I've also tried adding nomodeset in grub.

Here is every hardware related information for my PC, which may be necessary for information. It has Integrated graphics.

VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] (rev 83)

Update 1

I've attached important log messeges from Logs at the time of error.

12:33:22 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:33:22 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:33:22 PM kernel: INFO: task kworker/1:0:19 blocked for more than 241 seconds.
12:31:21 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:31:21 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:31:21 PM kernel: INFO: task NetworkManager:921 blocked for more than 241 seconds.
12:31:21 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:31:21 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:31:21 PM kernel: INFO: task kworker/3:3:356 blocked for more than 241 seconds.
12:31:21 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:31:21 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:31:21 PM kernel: INFO: task kworker/0:2:157 blocked for more than 241 seconds.
12:31:21 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:31:21 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:31:21 PM kernel: INFO: task kworker/3:0:31 blocked for more than 241 seconds.
12:31:21 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:31:21 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:31:21 PM kernel: INFO: task kworker/1:0:19 blocked for more than 120 seconds.
12:29:20 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:29:20 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:29:20 PM kernel: INFO: task NetworkManager:921 blocked for more than 120 seconds.
12:29:20 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:29:20 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:29:20 PM kernel: INFO: task kworker/3:3:356 blocked for more than 120 seconds.
12:29:20 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:29:20 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:29:20 PM kernel: INFO: task kworker/0:2:157 blocked for more than 120 seconds.
12:29:20 PM kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
12:29:20 PM kernel:       Tainted: G        W         5.4.0-42-generic #46-Ubuntu
12:29:20 PM kernel: INFO: task kworker/3:0:31 blocked for more than 120 seconds.
12:25:55 PM kernel: iwlwifi 0000:03:00.0: Failed to send binding (action:1): -5
12:21:28 PM bluetoothd: Failed to set mode: Blocked through rfkill (0x12)
12:21:19 PM kernel: ACPI Error: Aborting method \_SB.PCI0.GFX0._DSM due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
12:21:19 PM kernel: uvcvideo: Failed to query (GET_INFO) UVC control 8 on unit 1: -32 (exp. 1).
12:21:18 PM kernel: ACPI Error: Aborting method \_SB.PCI0.GFX0._DSM due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
12:21:18 PM kernel: DMAR: Failed to find handle for ACPI object \_SB.PCI0.SDHC
12:21:18 PM kernel: Initramfs unpacking failed: Decoding failed
12:21:18 PM kernel: ACPI Error: Aborting method \_SB.PCI0.GFX0._DSM due to previous error (AE_NOT_FOUND) (20190816/psparse-529)

Update 2

Answers mentioned in this question only tells either to delete log files. Till now I'm doing the same, but It hasn't solved the problem. Most of the time same problem occurs and even shutdown doesn't work. So, I used to shut down forcefully and then reboot in recovery mode to delete the log files from CLI.

Full version of syslog and kern.log at the time of the problem.

Update 3

As mentioned in this question. Answers to it only gives the solution to limit the size of the syslog and kern.log, but even If I limit the the size, but during that time I'll still face wifi driver issue and fan speeding up problem. It'll not solve the root cause of the problem.

Update 4

After seeing the log messeges, I thought the reason behind the problem was wpa_supplicant. So, I changed my wireless daemon on my Ubuntu from wpa_supplicant to iwd. It worked for two days, but then I faced the same problem of System hanging and Wifi disconnection, but this time there was no any logging of huge data in /var/log/.

14
  • Please check this : unix.stackexchange.com/questions/195360/… I hope it can be helpful Aug 10 '20 at 0:39
  • If I disable my wifi driver, then How can I use Internet. That's the last option one would try.
    – Kapil
    Aug 10 '20 at 1:15
  • It looks like your crash log is incomplete, so it's a little difficult to say what happened. Can you provide more? Is Secure Boot disabled in your BIOS?
    – heynnema
    Aug 10 '20 at 1:52
  • 1
    It says "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message" Mind also that the kernel claims it is tainted; could it be you added something to the kernel ?
    – Rinzwind
    Aug 10 '20 at 7:54
  • 1
    Does this answer your question? Very large log files, what should I do?
    – karel
    Aug 10 '20 at 7:55
1

I've changed my wireless daemon on my Ubuntu from wpa_supplicant to iwd.

  • iwd (iNet Wireless Daemon) is a modern, up-and-coming wireless daemon for Linux.
  • iwd is written by Intel and aims to replace wpa_supplicant.

Installation Instructions

  • Install iwd

    sudo apt install iwd
    
  • Configure NetworkManager to use iwd

    sudo gedit /etc/NetworkManager/conf.d/iwd.conf 
    
  • adding these two lines:

    [device]
    wifi.backend=iwd
    
  • Disable wpa_supplicant and reboot:

     sudo systemctl mask wpa_supplicant
     sudo reboot
    

Notes

  • If you had connected to any wifi network before. You just need to forget the connection and reconnect to transfer them into iwd’s secret storage at /var/lib/iwd/.

  • Sometimes after restart one can face the problem of no wifi in Network Manger even if you're connected. If It's the issue one can use systemctl to restart the iwd as mentioned above.

If any problem persists one can refer ArchWiki.

Note

Although It didn't solve my problem exactly, but has reduced the frequency of the problem, which is a big relief till now.


Reference:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.