So I first installed it onto my usb stick. Then checked things out with it, and decided to do a full install (replacing windows 7) which went well. It says to restart, which I do. But when its booting back up, it gets stuck on a black screen with a tiny little bar in the top left corner. Ive tried getting it to boot several times now, like changing the boot order and trying it back with my usb stick, but they all end with the black screen.

Os recovery is not an obtion. My laptop is a HP Pavilion dm1.

  • The pen drive linux. I used it several times before in the past while testing out 11.10 and 12.04. Never had any issues with it. – Andi Apr 27 '12 at 23:50
  • this is happening with me as well except I used unetbootin – Anake Apr 28 '12 at 0:15
  • 1
    In the end I used a CD and it worked fine, perhaps you should just bite the bullet? – Anake Apr 28 '12 at 0:51
  • Id consider a cd (would need to buy one first) but how will I know if it wont go to the black screen ehen I connect my external cd player, and will it even recongize it. :( – Andi Apr 28 '12 at 1:07
  • Can you not boot off the usb stick again to check? – Anake Apr 28 '12 at 1:09

The issue you have could be the one with Syslinux not booting on some systems. I had the same issue recently on a netbook, while never had it before anywhere else. While it booted and installed fine at first from the stick, it wouldn't boot neither from stick nor from the harddisk afterwards.

What I did is to grab the newest Syslinux 4.05 from http://www.syslinux.org/wiki/index.php/The_Syslinux_Project and update the 4.04 on the stick with it, by using syslinux.exe like described on that page under Windows. Right after that, I could boot again from the stick and repair the installation.

Maybe that helps in your case too.

| improve this answer | |

I had a similar problem when I tried to make a live USB for 12.04 with the "Unetbootin" application. If you are still worried or what not, I would suggest making a live USB with the dd command.

If you ever decide to do this, I would follow the directions of MikeWhatever's answer on this link.

| improve this answer | |

I think the boot order had to have the USB as the first to boot. I've done an installation of Ubuntu from a USB Flash Drive and I had to change the boot order to boot from USB first.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.