2

I am upgrading from 19.10 to 20.04 and I get a blackscreen on boot. In the past this has been a driver issue and I can clearly see the Segfaults or Kernel panics in the logs.
This time I don't know how to debug it. The dmesg and journalctl logs (are they the same log?) seem fine. I can get to the console via Ctrl + Alt + F2 so I can debug a bit.

Gist of the logs

Steps to debug:

  1. Install all updates
  2. sudo apt install --reinstall lightdm
  3. sudo systemctl restart lightdm
  4. It jumps me to tty 7 (I assume) and its a black screen, though my monitor doesn't turn off
  5. Repeat the above steps with gdm3 this results in gdm starting in tty2 and doesn't seem to have an effect

Of note, I have a dedicated graphics card and an integrated graphics chip, plugging my monitor into either nets the same results.
Any idea how I can debug this further? I can update the gist with any details necessary.

4
  • Does comment #6 here bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1757091 provide any useful information? Aug 15, 2020 at 5:27
  • 1
    Do you have any greeter installed, like 'lightdm-gtk-greeter' or 'lightdm-webkit-greeter'? Aug 16, 2020 at 12:29
  • Do you have more thhan one DE installed? Type ls /usr/bin/*session and can you confirm that your current one is in fact lightdm? Type echo $XDG_CURRENT_DESKTOP Aug 18, 2020 at 12:20
  • Hey All, I ended up removing lightdm, gdm3, and ubuntu-desktop and reinstalling the latter. That got the machine to boot to a desktop but the mouse was missing. I then tried a wayland session and that seemed to work. I think the tl;dr is that I need to back my data up and format the drive unfortunately.
    – Chris
    Aug 18, 2020 at 13:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.