I tried upgrading once more to 12.04 after it went live. I had tried both Beta 1 and Beta 2. The problem is that now I'm getting sporadic network connectivity. My computer is hooked up straight to my modem/router combo -- it is hardwired, so wireless can be thrown out of the question. My other devices (Computers, Phone, Tablets, etc) all are able to connect correctly and this is only happening with 12.04. 11.10 works like a charm.

Output for ifconfig -a is as follows:

Link encap:Ethernet  HWaddr 00:1e:2a:b2:4f:28  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::21e:2aff:feb2:4f28/64 Scope:Link
      RX packets:4093 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3531 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:3767248 (3.7 MB)  TX bytes:555829 (555.8 KB)
      Interrupt:22 Base address:0xec00 

Output for ethtool -S eth2 is as follows:

 NIC statistics:
 tx_packets: 870
 rx_packets: 854
 tx_errors: 3
 rx_errors: 1
 rx_missed: 0
 align_errors: 1385
 tx_single_collisions: 0
 tx_multi_collisions: 0
 unicast: 683
 broadcast: 57
 multicast: 114
 tx_aborted: 0
 tx_underrun: 0$

Output for netstat -i is as follows:

Kernel Interface table
eth0       1500 0         0      0      0 0             0      0      0      0 BMU
eth1       1500 0         0      0      0 0             0      0      0      0 BMU
eth2       1500 0       854      0      0 0           870      0      0      0 BMRU
lo        16436 0       215      0      0 0           215      0      0      0 LRU

Again, this is sporadic. It sometimes doesn't do this on startup, and sometimes does. It will work fine for 10 mins or so, then not work for hours, then work for hours. I'm not a network guy by any means so most of what I just posted is foreign to me - anyone have any suggestions as to what to check and what the RX-ERR and TX-ERR are?


  • To add to this - I have both an onboard NIC on my EVGA P55 SLI motherboard and a Realtek NIC. It had been plugged into eth2 which was my Realtek NIC, I've now switched it over to onboard NIC and it still continues to get a bunch of RX and TX Errors. – cloyd800 Apr 27 '12 at 23:55
  • 1
    Perhaps this is driver related, can you add what kind of NIC it is to your question? – Jorge Castro Apr 28 '12 at 1:07
  • got same issue but partial upgrade worked for me. – user68161 Jun 3 '12 at 20:14
up vote 2 down vote accepted

I was able to fix this issue by turning off automatic detection of my NIC and manually adding the Gateway, Address, and Mask IP's pointing directly to my router.

I used this answer to a previous question - No internet connection, ifconfig shows errors

I had the same problem. I turned the wireless LAN OFF and then turned ON. This seems to have resolved the issue on my side.

Use System settings => network => Wireless => ON/OFF

I have not seen the Internet connection issues since 24 hrs.

I hope this helps for others as well.

This only works if you have NOT upgraded already to 12.04. It is not an option for those of us who made the mistake of actually loading the full upgrade, but thank you.

This happened for me also. I did the following steps and everything was alright.

  1. Go to the top right of the screen.
  2. Choose "Software up to date" from the menu
  3. Do a partial upgrade

Ref: http://blog.sbw.be/2012/04/28/upgrading-from-ubuntu-11-10-to-12-04lts/

(temp) SOLVED: I had the same issue. But because I came from upgrading instead of fresh installing. In the boot options, I selected the previous boot option with different kernel. My option kernel is "" and after login, it works! Seems to me that the kernel in this new upgrade still has some bugs to fix!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.