I already tried what is suggested in the answer to the question: "I got an error when trying to install a latex package trough tlmgr on ubuntu 20.04, verify_checksum: -5 ".

When I type this command: tlmgr --verify-repo=none install beamer I get:

(running on Debian, switching to user mode!)

tlmgr: Local TeX Live (2019) is older than remote repository (2020).
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
See https://tug.org/texlive/upgrade.html for details.

I went to the link above (https://tug.org/texlive/upgrade.html) and as is suggested there, in the first place, i tried a "new installation" of texlive-latex-extra but nothing changed. So I followed the guide. At the first point it says that the parent directory should be:


and that, inside texlive directory, I should find a 2019 (or 2020) directory but the only directory I have is: texmf-local:

ale@ale-ThinkPad-L13-Yoga:~$ ls /usr/local/texlive/

Eventually I looked for a "texlive/2019" or "texlive/2020" directory, but there are none:

ale@ale-ThinkPad-L13-Yoga:~$ sudo find / -iwholename */texlive/2020/*
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied
ale@ale-ThinkPad-L13-Yoga:~$ sudo find / -iwholename */texlive/2019/*
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied

I thought again that I did a wrong installation of texlive-latex-extra but after a reinstallation of "texlive-..." the problem was still there??

2 Answers 2


The short solution is: this error is because you're using wrong repository version. Your TexLive 2019 is trying to use a TexLive 2020 ftp repository.

You should change to the right (correct) repository. Type this commands in a Terminal:

tlmgr repository add ftp://tug.org/historic/systems/texlive/2019/tlnet-final
tlmgr repository list
tlmgr repository remove http://mirror.ctan.org/systems/texlive/tlnet
tlmgr option repository ftp://tug.org/historic/systems/texlive/2019/tlnet-final

After that you can install the package with this command:

tlmgr --verify-repo=none install dirtree

I added the --verify-repo parameter to avoid get this error: tlmgr: unexpected return value from verify_checksum: -5 for main repository

  • 1
    This didn't help me unfortunately. The latex maintainers didn't think about backward compatibility at all it seems. Very frustrating. Mar 15, 2021 at 21:40
  • I've test in my own computer and it works! Mar 16, 2021 at 0:54
  • @SridharSarnobat which is your problem? can you show me a screenshot or the error message? I can help you Mar 31, 2021 at 2:29
  • Thanks for the offer. It's been a few weeks and I've probably reinstalled the latest version so can't reproduce it now. I'll follow up here if I see it again. Mar 31, 2021 at 21:19

Personally I would recommend to install all the LaTeX stuff from official Ubuntu repository.

For Beamer use :

sudo apt-get install texlive-latex-recommended

as it contains needed beamer.cls. You will get not too old 2019 version which is really enough to typeset documents. Newest 2020 is not needed here at all.

  • Thank you Norbert! Before I install texlive-latex-recommended, I would like to know if I'll still have problems (like the ones I mentioned above) using tlmgr for future installation of latex packages ?
    – alessandro
    Aug 8, 2020 at 16:06
  • You may have the problems if you want to mix tlmgr with deb-packages. Using deb-packages only is safe.
    – N0rbert
    Aug 8, 2020 at 16:11
  • I've installed "texlive-latex-recommended" but I still have this strange directory tree: ` ale@ale-ThinkPad-L13-Yoga:~$ ls /usr/local/texlive/ texmf-local ` instead of "/usr/local/texlive/2019(or 2020)" as indicated in the [tug.org/texlive/upgrade.html]
    – alessandro
    Aug 8, 2020 at 19:00
  • I have never installed TexLive to /usr/local/texlive/ . Consult with its official documentation about removal.
    – N0rbert
    Aug 8, 2020 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.