3

I use a chess application called "Lucaschess" and it needs PyQt4 module to work. Is it possible to install Pyqt4 on Ubuntu 20.04? I understand that Ubuntu no longer supports this package but is there anyway which I can work around?

8

The Qt4 packages can still be obtained from third party PPA:

sudo add-apt-repository ppa:rock-core/qt4
sudo apt-get update

Then you have to download python-qt4 binding from previous Ubuntu 18.04 LTS release manually:

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/universe/q/qt-assistant-compat/libqtassistantclient4_4.6.3-7build1_amd64.deb
sudo apt-get install ./libqtassistantclient4_4.6.3-7build1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/python-qt4/python-qt4_4.12.1+dfsg-2_amd64.deb
sudo apt-get install ./python-qt4_4.12.1+dfsg-2_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/universe/p/python-pyaudio/python-pyaudio_0.2.11-1build2_amd64.deb
sudo apt-get install ./python-pyaudio_0.2.11-1build2_amd64.deb

As the result the Python2-Qt4 binding will be installed. Then you know what to do.

Also note that there is fresh version of lucaschess here with Qt5 as dependency.

4
  • I have added installation of python-pyaudio. How did you installed LucasChess? There is a PKGBUID for ArchLinux, but looks very complicated. This is why I am asking. – N0rbert Aug 8 '20 at 9:05
  • Yeah i installed by the following the instructions here: github.com/lukasmonk/lucaschess/blob/master/Linux/… and got the pyaudio error. – crskhr Aug 8 '20 at 11:43
  • 1
    By the way, lucaschess is working now. Thanks a ton! – crskhr Aug 8 '20 at 11:45
  • The following packages have unmet dependencies: libqtassistantclient4: Requires: libqt4-network (> = 4: 4.8.1) but cannot be installed – Adam May 1 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.