21

I am currently using 18.04 LTS in the web server production environment. I was under the impression that Ubuntu 20.04 LTS was ready to go, since it was released in april 2020.

But running do-release-upgrade tells me "There is no development version of an LTS available".

Does this mean that 20.04 LTS is not ready yet?

1
  • LTS users usually want stability, so the upgrade doesn't occur until AFTER the first point release (which is likely in hours). Even after 20.04.1 has been released (which is actually the date/time for the ISO release for new installs), it's a number of days before the taps get turned allowing the prior LTS release to detect and offer upgrade; which ensures stability. – guiverc Aug 6 '20 at 12:38
10

Upgrade from 18.04 is done with 20.04.1 (note the .1).

That point release is set for release on august 6th 2020. So you need to wait a little bit longer as it is not the 6th all over the world yet.

It was initially set for July 23rd but that got postponed to Aug 6th.

17
  • 17
    Well, as of today (7th August in the UK) My 18.04.4 system is still not seeing the 20.04.1 LTS upgrdae as being available. do-release-upgrade returns the message There is no development version of an LTS available so I'm upgrading with do-release-upgrade -d which says its upgrading to 20.04. – Fat Monk Aug 7 '20 at 10:22
  • 6
    and now it is the 12th of august, and still "There is no development version of an LTS available." When precisely is it expected to become available? – Rhialto supports Monica Aug 12 '20 at 16:52
  • 4
    Aug 13, on Ubuntu 18.04.5 LTS. Without -d, I still get "There is no development version of an LTS available". Do you guys know where to find some more info on the general availability? – rdesgroppes Aug 13 '20 at 10:16
  • 2
    So it's 14th, more than a week later and still "There is no development version of an LTS available." both from do-release-upgrade and software updater. So I tempted to downvote this answer as completely incorrect unless some information w.r.t. delay is added (i.e. if there is some critical bug delaying the roll out or something else). – Dan M. Aug 14 '20 at 17:46
  • 2
    And now it's the 29th and it's still not yet ready. :\ – James T Snell Aug 29 '20 at 16:42
44

According to the Focal Fossa (20.04.1 LTS) Point-Release Status Tracking page, upgrades are not enabled yet due to "a few upgrade blockers".

This issue was reported as bug #1890936.

5

Not the answer you're looking for? Browse other questions tagged or ask your own question.