0

I am newbie on linux system. My laptop is ASPIRE 4752 where definitely is old machine without UEFI, only legacy BIOS.

My current OSes installed are WIN 8.1 and Xubuntu 18.04-instaling after windows, both OS is x64 works find on dual boot, installed on legacy BIOS mode.

When i try to install/upgrade Xubuntu 20 via usb stick, i found this issue windows 8.1 not in list only Xubuntu 18.04

Next i decide to choice something else menu then setup the path of root and home same as xubuntu 18. When i next to install i got warning about EFI partition doesn't exist. warning about EFI partition not exist

So i decide to quit and still keep on Xubuntu 18.04. I assume if Xubuntu 20 have issue with fully legacy BIOS (old BIOS) as i know today all new machine have dual BIOS.

Because when install Xubuntu 16 18 alongside windows, i didn't meet this situation, Windows 8.1 show in list. Only lost windows boot loader but can fix it by fixmbr on windows, next update grub on xubuntu.

Please help how to install/upgrade xubuntu 20 alongside windows 8.1 with legacy BIOS mode on ASPIRE 4752 via usb stick.

Thank you,

  • You would not get the ESP does not exist unless you booted installer in UEFI boot mode. Are you sure system is not UEFI? But if Windows is BIOS/MBR partitioning then you want new install to also be BIOS. How you boot install media UEFI or BIOS is then how it installs. Some tools to create install flash drive, only make UEFI or only BIOS installer, so make sure installer is also correct boot mode. Shows installer with screen shots. Both BIOS purple accessibility screen & UEFI black grub menu screen help.ubuntu.com/community/UEFI – oldfred Aug 6 at 14:02
  • I used rufus to create flash drive and set to BIOS/MBR mode (non-EFI). Also try to create flash drive using Universal USB Installer, where as i know is for BIOS. When installing Xubuntu 18, i create the flash drive using Rufus 3.8. So basically i do same for Xubuntu 20, but the result is different. – Alfan Aug 6 at 14:14
  • Yes, i really sure, Acer Aspire 4752 not using UEFI Bios. – Alfan Aug 6 at 14:21
  • Are you getting purple boot screen as shown in link above? That is the BIOS boot screen. – oldfred Aug 6 at 15:04
  • On xubuntu 20, shown boot logo with checking system files. I think it's same like i install xubuntu 18 or as you mentioned. – Alfan Aug 7 at 2:21
0

Finally i can solved the problem. At least in my case.

  1. Create Xubuntu 20 installer using Rufus 3.11.
  2. On Rufus option: Partition MBR, system BIOS, check add fixes for old BIOSes-it's optional.
  3. Choice write image in "DD image mode"
  4. Finish creating the image, open explorer then go to flashdrive. Delete efi folder. I think this important step to force xubuntu installer boot on legacy Bios.

before thise step, i can't see this menu windows partition shown

Noted: In my investigation, this step applicable also for modern BIOS (dual BIOS).

If create xubuntu installer using ISO mode, the step also same, just delete EFI folder to force Xubuntu booting using legacy BIOS. Hope this trick can help anyone who headache during install Xubuntu (or maybe Ubuntu) alongside windows with legacy Bios.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.