1

I just downloaded the Ubuntu 20.04 WSL in Windows 10, however, I cannot install R. In view of this, I have tried to install build-essential, but it is still unsuccessful as the cpp, gcc, g++ cannot be installed as well.

enter image description here

1
  • is your problem solved? – Yeppii Sep 24 '20 at 16:34
0

Check your internet connection. The screenshot shows connection failed, so check your internet connection. Here are some tips:

  • Turn off any VPN.
  • Turn off Windows Firewall in Windows Security.
  • Check your router or wifi connection.
  • Make sure that you have not set a static IP.
  • Make sure that you dont have an http://archive.ubuntu.com entry in your hosts file that is located under C:\Windows\System32\drivers\etc.
  • Also, check the /etc/hosts file in your Ubuntu installation.

I hope that this information will be useful to you and other people who are visiting this question.

1
  • 1
    Sorry, I still encountered the same problem after following your instruction. 1. Turn off windows firewall 2. wifi connection set to private, IP setting: Automatic (DHCP) and random hardware address: on 3. I have checked the host files, no any ubuntu files – mandy Aug 7 '20 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.