Possible Duplicate:
Menu missing in Lotus notes 8 and Eclipse in Unity

I downloaded Eclipse Indigo from the Eclipse website and tried to run it on Ubuntu 11.10, but the menus do not show up in the global menu or in the app.

Before anyone marks this a duplicate, I have already seen the other questions and the bug reports on both Launchpad and the Eclipse bugtracker. I have tried the workarounds (unsetting UBUNTU_MENUPROXY or setting APPMENU_DISPLAY_BOTH) suggested in each of those threads. None of the suggested workarounds worked and every single thread just suggests the UBUNTU_MENUPROXY workaround followed by lots of "thanks that worked". I've even tried running Eclipse in environments that don't have a global menu like gnome-shell or the gnome fallback session and it still doesn't show the menu anywhere.

The only thing that works is running Eclipse with sudo (which is a terrible idea).

This is very frustrating and I am wondering if anyone has any other solutions because this makes Ubuntu pretty much useless for any type of development requiring Eclipse.

marked as duplicate by Jorge Castro, Marco Ceppi Apr 30 '12 at 2:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please don't just post another question for an open issue, it will jsut confuse people. This is a bug report that we can't do much about. – Jorge Castro Apr 30 '12 at 1:56

I am using Eclipse Indigo 3.7.0 on two PCs, a 5 year old laptop (32bit Ubuntu 11.10) and a new built PC (64bit Ubuntu 11.10). The menu colors of a selected menu item could have been more visible relative to the background, but else the menus are working.

You say you downloaded from the Eclipse website. I downloaded Eclipse Indigo the following way in the Terminal:

sudo apt-get install eclipse eclipse-cdt eclipse-JDT

(another post in this forum recommends this: sudo apt-get install eclipse eclipse-jdt eclipse-pde eclipse-platform eclipse-rcp)

For a 64 bit Ubuntu, you may need this as well:

sudo apt-get install ia32-libs-multiarch

Not the answer you're looking for? Browse other questions tagged or ask your own question.