71

I have recently created an Ubuntu 12.04 partition on my Windows 7 laptop. When installing it, I switched to "high contrast" mode, which has rather large cursors (by large I mean about twice as large and thick as they should normally are).

Now I have successfully installed the partition, the large cursors have stuck around even after exiting this high contrast mode, but only when I am hovering over stuff e.g. hovering over text inputs, links, and when resizing windows. All of these cursors are too large. They cursor is only normally sized when the computer should be displaying the normal mouse pointer.

Does anyone know how I might go about fixing this?

79

I would suggest you update your cursor theme and cursor size.

First in a terminal type:

sudo update-alternatives --config x-cursor-theme

enter image description here

Choose the number of the theme you want - e.g. 0 for DMZ-White

Changing the value here requires a reboot - a logout and login will not suffice.

Secondly, using dconf-editor (install using sudo apt-get install dconf-tools)

enter image description here

navigate to org.gnome.desktop.interface

change the cursor size to 24 and cursor theme to DMZ-White

  • Thank you very much! That would have driven me to insanity after a couple more hours. – Tom Apr 27 '12 at 23:21
  • 3
    The location has changed in 14.04 (I used CTRL-F to find \cursor-size) but I find the value is reset after a reboot? – LeeGee Apr 2 '15 at 8:03
  • Weird that these kind of mouse settings don't come up in System Settings->Mouse and Touchpad! – neuronet Jul 11 '16 at 12:43
  • update-alternatives: error: cannot stat file '/etc/alternatives/x-cursor-theme': Too many levels of symbolic links – Aaron Franke Dec 13 '16 at 1:20
  • 2
    Doesn't work on Ubuntu 18.04. – Alex Yakunin Sep 17 '18 at 23:58
28

For a command-line / automated way of doing it, try:

dconf write /org/gnome/desktop/interface/cursor-size 48

Works for me on Ubuntu 16.04.

Some time in the past, I wrote that "in 18.04 LTS there is one new key" (below), but I don't know why I wrote that. The command below doesn't work on 18.04 for me now, while the dconf command above does (but doesn't persist.)

gsettings set com.ubuntu.user-interface.desktop cursor-size 48
  • Sometimes life is easier, if you know how to live.... Like this answer :D – nehemiah Nov 3 '16 at 4:20
  • Gah, in recent months I've noticed this settings gets reset to a normal cursor size, maybe on reboot. I'm on 16.04 now, but don't know when this started happening. :-( – Jonathan Hartley Dec 6 '16 at 21:06
  • perfect! this should be the accepted answer! – ccpizza Dec 3 '17 at 16:17
  • same here, on 16.04 this gets reset on boot – xdavidliu Mar 13 '18 at 19:42
  • 1
    for 16.04 I suggest using unity tweak tool, as per this question – xdavidliu Mar 13 '18 at 20:23
4

it's very clunky, but do-able.

  1. Download your favorite cursor theme from Gnome Look or other sources, and untar it in the folder you downloaded.
    enter image description here
  2. Next, open a terminal and type sudo nautilus and a Root Nautilus will launch. BE VERY CAREFUL DELETING AND MOVING FILES IN IT enter image description here
  3. Now, go to your downloads folder (from the Root Nautilus you just opened) and copy the folder of the downloaded cursor theme (not the .tar archive)
  4. After doing so, go to /usr/share/icons and paste the folder of the cursors. but don't close it just yet. enter image description here
  5. Within the 'icons' folder you'll see a 'default' folder - open it - and open the 'index.theme' file (in gedit, in-case it doesn't open automatically), and change the theme name to the name of the cursor folder you copied (for example: 'neutral'). save and close the file. enter image description here enter image description here
  6. Almost done. Now install Gnome/Unity Tweak Tool and change the cursor theme within them. enter image description here In the Gnome Tweak Tool it look like this: enter image description here
  7. Log out and log back in and you're set.

Truly Canonical and the Ubuntu community need to do some work for this in terms of End-User customization, but bottom line is that this works.

  • Upvote for this. However I got stopped at step 1. This answer says to download my favorite mouse theme. Huh? – SDsolar May 3 '18 at 1:32
1

Try change the setting in gconf-editor (Alt F2, gconf-editor). It is either under

/desktop/gnome/peripherals/mouse/cursor_size

or

/apps/compiz/general/allscreens/options/cursor_size
  • doesn't work for me. Are there another solutions? – user20959 Oct 14 '11 at 15:07
  • Thanks, but this didn't work for me. – A B Dec 4 '11 at 8:58
  • Are they the same option (symlinked), or different ones? – lindhe Jun 23 '17 at 8:05
1

Check your mouse theme using the dconf-editor:

  1. Install the package dconf-tools Install dconf-tools
  2. Run dconf-editor

  3. Navigate to org.gnome.desktop.interface and check the mouse cursor settings:

enter image description here

DMZ-White should be set as the theme. Then log out and back in and see if you still have the problem.

References:

  • Thanks, but this didn't work for me. – A B Dec 4 '11 at 8:59
  • On my Linux 3.0.0-14, Ubuntu 11.10, metacity 2.34.1 system, using dconf-tools to change the cursor-size number changes the cursor size in several kinds of windows, such as in firefox, gnome-terminal, pan, thunderbird, but does not change its size in emacs, dconf-editor, tool bar, et al – James Waldby - jwpat7 Dec 18 '11 at 2:01
  • The application of cursor theme isn't consistently handled in 11.10. Changes as above indeed don't impact the normal cursor pointer but do take effect in some cases like when hovering over a link or within a text entry field both the cursor size and theme set in dconf are used not for the cursor displayed while moving around the screen. – fragos Jan 6 '12 at 2:45
  • this gets reset after reboot in 16.04 – xdavidliu Mar 13 '18 at 20:10
  • Upvote for the command and thorough screenshots. But if it gets reset at boot it will only last until the next software update. Darn. – SDsolar May 3 '18 at 1:33

protected by Community Mar 20 '13 at 18:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.