0

I am trying to set a profile persistently across reboots. Manually doing the following works:

$ pulseaudio --start
$ pacmd set-card-profile 0 'output:iec958-stereo'

But, it is not persistent across reboots, so I edited ~/.config/pulse/defult.pa appending another line:

set-card-profile 0 'output:iec958-stereo'

Adding the line to the end of default.pa causes pulseaudio to refuse to start with the error 'Daemon session failed.'

How can I keep the profile setting persistent across reboots?

1 Answer 1

4

Remove the single quotes.


I would also suggest using the name of the devices rather than their index, as this index might change if you start connecting more devices.

➜ pactl list cards short                               
0   alsa_card.pci-0000_01_00.1  module-alsa-card.c
1   alsa_card.pci-0000_00_1f.3  module-alsa-card.c

Inside ~/.config/pulse/default.pa choose card name and set your profile for it:

set-card-profile alsa_card.pci-0000_01_00.1 output:iec958-stereo

Restart pulseaudio, or re-login

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .