Acer Spin 5 SP513-52N, dual-boot with Windows 10

I installed Ubuntu 20.04 yesterday, and it worked well, but after a restart today, there was a black screen and the following information:

/dev/sda6: clean, nnn/nnn files, nnn/nnn blocks

I waited for several hours, but there was no progression from the screen.

After searching for similar questions, I tried the following (mostly from the step-by-step from @heynnema in "dev/sda1: clean, ..." This message appears after I startup my laptop, then it won't continue booting):

Attempt 1:

sudo fsck -f /
/dev/sda6 is mounted. e2fsck: Cannot continue, aborting.

sudo mount -o ro, remount /
mount: /: mount point is busy.

Attempt 2:

sudo blkid
sudo cat /etc/fstab

blkid fstab

Attempt 3:

In Windows 10, unchecked fast start, in the command prompt window typed powercfg /h offwhich gave me

Unable to perform operation. An unexpected error (0x65b) has occurred: Function failed during execution.

Attempt 4:

sudo apt-get purge nvidia*

I got several lines of:

Package 'nvida-xxxx-xxx' is not installed, so not removed
The following packages were automatically installed and are no longer required:
libllvm9 python3-click python3-colorama
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.

sudo ubuntu-drivers autoinstall

No drivers found for installation

For the last attempt, I'm not sure if it's because of the wifi disconnecting problem that I had before this. Windows 10 did not have the wifi disconnecting problem.

There were suggestions on using Ctrl+Alt+F2 or F3, but I couldn't figure out when to press that (before GRUB menu? After selecting Ubuntu to boot?).

Edit: Boot-info URL: paste.ubuntu.com/p/N7p5kmgvGG/

Edit 2: Updated UEFI from latest Acer update. Selected shimx64.efi as trusted (from list of fwupx64, grubx64, shimx64, mmx64). Laptop booted directly to Windows10 but GRUB menu didn't appear at all. A check of the partitions showed that Ubuntu was still there (something was taking up the space anyway), then it restarted into Preparing Automatic Repair and stayed there.

Tried several hard shut downs, but still got the automatic repair. Unable to boot into recovery mode using Shift/Esc.

  • 1
    Did you have to set "trust" like: askubuntu.com/questions/908854/… If you have Intel graphics, you do not need nVidia. Have you updated UEFI from Acer? Even new system may need that. Lets see details, use ppa version with your live installer (2nd option) or any working install, not older Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair – oldfred Aug 5 '20 at 13:33
  • I didn't understand about UEFI/BIOS and enabling trust. – allie Aug 5 '20 at 15:04
  • Boot-info URL added. If I understood correctly, I should not run Boot-Repair - not yet (which I didn't). – allie Aug 5 '20 at 15:11
  • Not showing any nVidia. For Windows can you boot it at immediately press f8 for repair console? Otherwise you need Windows repairs which is beyond this question & answer site. If you follow link it discusses Acer & trust. But then UEFI entry is normallly "unknown". Yours shows Ubuntu. Have you updated UEFI from Acer? Are you getting grub terminal or booting recovery mode & getting Ubuntu terminal or recovery menu? – oldfred Aug 5 '20 at 16:33
  • I haven't updated UEFI - there are 10 updates here: [link] (acer.com/ac/en/US/content/support-product/…) . Do I update all 10? I think I understand how to do it. The screen goes to GRUB menu, then I get to choose Ubuntu, Advance Options for Ubuntu (which is where I boot into recovery mode and access the root terminal), Windows Boot Manager, and System Setup. After installing Boot-Repair, System Setup has changed to UEFI Firmware Settings. – allie Aug 6 '20 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.