5

Possible Duplicate:
Brightness controls doesn't work on a MacBook Pro 5.5

I recently installed Ubuntu 12.04 LTS on my MacBook pro 5.5 (mid 2009). I have a problem with the brightness control. The thing is, when I try to reduce the brightness of my display which would help my battery and also not burn a hole through my eyes, is doesnt work.

I tried to use the system preference but nothing. The brightness control brightness slider doesn't even work. The only time the screen with change brightness is when ubuntu wants to go to sleep.

I went to the Ubuntu wiki or whatever it is and went through the MacBook Pro compatibility stuff to no avail.

I'm not sure if this has been asked allot or not, but I'm unable to find a solution. I am also new to ubuntu/linux but want to make the change and learn all I can.

P.s.- is there anything out there that will make the touch-pad work really well, I've already played with the mouse/track-pad settings that comes with Ubuntu? It's working but there seems to be some sluggishness and a few glitches here and there.

Thank you in advance =)

9
  • 1
    One question at a time please :-) For your brightness control, see if this works. If it doesn't, you might need to change graphics driver (if you are using the default). Post your trackpad question separately. It should be easy to fix. Apr 27, 2012 at 20:42
  • Is there a preferred graphics driver people use over the default?
    – Barkerto
    Apr 27, 2012 at 21:13
  • You didn't say whether the command line worked :-) Well, switching drivers is a funny business.. you can fix one thing but break another. But in answer to your question, it depends on the graphics card you have. The default for nvidia has no power management, so people may switch to the proprietary driver if battery life on a laptop is important to them, but nvidia's drivers (being closed source) may not play nice with Ubuntu (leading to display issues like tearing in video). Apr 27, 2012 at 21:30
  • Alright, Thank you. I'll check out the nvidia driver on their site (I'm guessing that's where I would find the drivers). But before that let me check the command line. I'll get back to you shortly.
    – Barkerto
    Apr 27, 2012 at 21:50
  • Alright, so I tried the command lines in the link. It would change the brightness variables but it still wasn't changing the actual brightness of the screen. Could it possibly be that I'm running 64-bit instead of 32-bit?
    – Barkerto
    Apr 27, 2012 at 22:00

1 Answer 1

6

First, see this for instructions on changing brightness through the command line. If that doesn't work, it is likely a problem with your graphics driver and/or kernel version.

Note that by switching graphics driver, you can solve one problem but cause another. The default for nvidia has no power management, so people may switch to the proprietary driver if battery life on a laptop is important to them, but nvidia's drivers (being closed source) may not play nice with Ubuntu (leading to display issues like tearing in video).

If you want the nvidia driver, type in the terminal sudo apt-get install nvidia-current. After installing the driver, you'll need to enable brightness controls in /etc/X11/xorg.conf.

In /etc/X11/xorg.conf you should put:

Section "Device"
    Identifier     "NVIDIA GeForce"
    Driver         "nvidia"
    Option         "NoLogo" "True"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

"Identifier" is not so important unless you have other stuff referring to this device in your conf file. You can replace with more appropriate name if it's not an Nvidia GeForce type card. Everything else must be as written; "NoLogo" is to avoid the annoying Nvidia splash screen.

To edit the file using a GUI text editor, type gksudo gedit /etc/X11/xorg.conf in the terminal. Save changes and reboot... if all went well, you will now be using the new driver and brightness controls will work! If it doesn't work, you can check if you're using the new driver by typing in the terminal lspci -v | grep -i -A 15 vga. You should get something like:

02:00.0 VGA compatible controller: NVIDIA Corporation Device 08a3 (rev a2) (prog-if 00 [VGA controller])
[some lines omitted....]
Kernel driver in use: nvidia
Kernel modules: nvidia_current, nouveau, nvidiafb

Kernel drive in use should be nvidia, not nouveau.

6
  • Yes, I switched, sorry I thought I typed that out. I'm not trying to input the proper formatting into the conf file now. But when I try to save it's telling me that I don't have permission to do that. I'm the only user of this computer, is this referring to admin only (which i am the admin of course), or something that I'm missing?
    – Barkerto
    Apr 27, 2012 at 23:06
  • GOT IT!!!! Thank you so much! I just had to use sudo gedit /etc/X11/xorg.conf and then edit the file respectively. Thank you!!
    – Barkerto
    Apr 27, 2012 at 23:17
  • In case someone has this problem and they don't have the file /etc/X11/xorg.conf: I installed Xubuntu 18.04, and the file /etc/X11/xorg.conf did not exist. Taking a look at this answer here, I found /usr/share/X11/xorg.conf.d/<nvidia>.conf and I added Option "RegistryDwords" "EnableBrightnessControl=1" to the configuration and it worked.
    – ialm
    Apr 22, 2020 at 3:46
  • Actually, following the conventions according to the answer that I found in another answer here, I copied the original conf file from /usr/share/X11/xorg.conf.d/<nvidia>.conf to /etc/X11/xorg.conf.d/ and made my changes there.
    – ialm
    Apr 22, 2020 at 4:16
  • By <nvidia>.conf do you mean, for example, the file on my system 10-nvidia.conf ?
    – Yu Buntu
    Dec 7, 2021 at 3:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.