I recently upgraded from Ubuntu 18.04 to Ubuntu 20.04.

The desktop background has a bit of a strange issue. It seems like all my icons have been duplicated, and 1 set of that is actually part of the background. Not clickable, not selectable by dragging the mouse.

They're just there, in the left corner. And the other ones were on top of them. I can move the 2nd group around, no problem. But the first one stays in place and remains unusable.

No matter what I change the background to, this doesn't change.

What can be done here?


Only modifications I ever did was putting the dock on both screens.

Login happens with the default option, "Ubuntu". Other option is "Ubuntu on Wayland" and a 3rd option is Xfce. I don't recall ever using that, but it's possible I installed it once for some reason.

Output of gnome-extensions list --enabled:

[email protected]
[email protected]

I don't recall ever installing a gnome extension myself.

Login in to Wayland has identical issues.

  • It almost sounds like type of problem when a second different desktop is added. Did you modify, (not add another) your desktop in 18.04?
    – crip659
    Aug 2, 2020 at 11:29
  • When logging in you should have a choice between using Xorg and wayland, would suggest choosing the other one that you use and see if any difference.
    – crip659
    Aug 2, 2020 at 11:51

2 Answers 2


As you have mentioned you have 'Xfce' as a third choice while logging into Ubuntu, it is highly likely that you have installed the Xfce desktop environment on top of the default GNOME 3 one.

Thus presumably you also have the xfdesktop4 package installed in your system too (you can check that by running the apt policy xfdesktop4 command in Terminal), which handles the desktop icons in the Xfce desktop. But the desktop icons are handled by a GNOME Shell extension called 'Desktop Icons' (package name: gnome-shell-extension-desktop-icons) in the default GNOME desktop. It seems in your case both are creating desktop icons, that's why all your icons on the desktop have been duplicated.

You can fix this by disabling one of the options. For example, you may launch the 'Extensions' application and turn off the 'Desktop Icons' extension.

  • I'll try that when I got some more time with the machine. Thanks for the advice.
    – KdgDev
    Aug 5, 2020 at 18:00

I've had the same problem with duplicated icons on desktop. In my case I 've had installed both Nautilus and Nemo, with nemo handling desktop Icons enabled with:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

gsettings set org.gnome.desktop.background show-desktop-icons true

gsettings set org.nemo.desktop show-desktop-icons true

I've solved the issue removing Nautilus file manager and leaving only Nemo that is my preferred file manager and desktop icons are not more duplicated.

for me the working solution was :

sudo apt remove nautilus
  • 1
    sorry for my mistake, it was an editorial fault, thanks for your comment. I have corrected the post.
    – pat
    Feb 21, 2021 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .