Yesterday I upgraded from Ubuntu 11.10 to 12.04. The upgrade went smoothly. I did a restart and then strange things started to happen.

After each upgrade I set my Ubuntu to automatic login(been upgrading from 10.04 until now without a fresh installation, always 64-bit). As expected yesterday the login window appeared. The first thing that caught my eye were the lines below my user name. They say "No value has been set". Then I type in my password as usual. And then the big one: "Invalid password, please try again"!

From that time on I tried a couple of things:

  1. Tried my different passwords. I always use the same password for Ubuntu but still I gave it a shot.

  2. My default language in Ubuntu is English. That is different from my keyboard layout that has a Slovenian layout. It has been a problem before that our Slovenian layout keyboard and English OS don't always cooperate as they should. That is the reason my Ubuntu password has only numbers and English letters. So I tried the on screen keyboard in Ubuntu to click my way through the login again no success.

  3. Then I tried to change my password. I followed these instructions. First through GRUB. After typing in "passwd myusername" I got a puzzling response. The terminal said:
    passwd: Authentication token manipulation error
    passwd: password unchanged
    The file system state was read/write because I used fsck command before going into root. Then I tried the second option with the Live CD. Erased the password from the shadow file but still no success logging in Ubuntu.

Then there is the thing with the Guest session account. No matter which option I choose (Ubuntu, Ubuntu 2D.) and login nothing happens. The screen goes blank for 3 seconds, the hard disk makes some noise and the login screen comes back on.

Now I don't know what to do next. I have a dual-boot system and Win7 boots up without problems. Ubuntu 11.04 runs great from Live CD. I did a memtest just to be sure and there were no errors. So I am kind of certain it is not a hardware problem.

Link to the contents of lightdm.log.

If you require any further information or if I was unclear please let me know! What else can I do?

  • can you change to a virtual console and have a look at the lightdm log ? sudo less /var/log/lightdm/lightdm.log – martin Apr 27 '12 at 18:58
  • Virtual console that is accessible by pressing CTRL+ALT+F1? That worked just one time and I couldn't login there either. If I do that now the screen goes blank and monitor shuts down completly. If use CTRL+ALT+F7 the login screen comes back up. Now I went and checked /var/log/lightdm/lightdm.log with a LiveCD. I am not sure what to watch for. Can I post the .log somewhere or send it to you? – eMKi Apr 27 '12 at 19:44
  • Please use ubuntu paste bin and edit your post and add the link to it. – martin Apr 27 '12 at 20:01
  • Link to the lightdm.log added. – eMKi Apr 27 '12 at 20:15
  • Can you try booting into console mode and see if your password works then ? Please see this post how to boot into console mode. Add text in the "linux /boot/vmlinuz..." after "quiet splash" – martin Apr 27 '12 at 20:53

I had a similar problem. After upgrading to 12.04, I could not login anymore, neither from the GUI nor from the console. After booting in recoverymode (see here) and mounting / read-write, changing the password via passwdusername seemed to work, but I still could not login afterwards.

The problem was in /etc/passwd. My shell was set to /usr/bin/tcsh, which does no longer work. It must be /bin/sh. (I personally find it sad that Ubuntu forces me now to use this shell, but I can workaround it).

By the way, I found it because I deleted the user via userdelusername and recreated the user useraddusername, and afterwards it worked. I had to fix the user and group number in passwd manually afterwards, that is the exact steps were:

  • move home directory to somewhere else (to avoid that userdel would remove it)
  • look into /etc/passwd and write down the group and user number (normally 1000)
  • userdel myusername
  • useradd myusername
  • passwd myusername
  • edit /etc/passwd to ensure that the group and user number is still the same
  • move home directory back to its original plase
  • login myusername => to test that it works now

Then I saw that the shell changed and I tried to change the shell (useradd -s /usr/bin/tcsh myusername) and then nothing worked again. So, stick with /bin/sh.

| improve this answer | |
  • Thank you for your time and your solution. I haven't tried it though because I did a quick reinstall and everything worked afterwards. Thank you anyway! – eMKi May 21 '12 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.