0

From the top of the terminal you can see the program being configured.  At the bottom you can see I try to run the make file but it says there is not one.  I run ls and there is clearly a makefile right there in the directory.

Before you tell me to read some wiki or installation guide, I already have read multiple and followed them step by step word for word.

I ran ./configure already I have gcc and cc installed.

10
  • Is the m4 package installed on your system? FYI neither Makefile.am nor Makefile.in are makefiles Aug 1, 2020 at 1:07
  • "you must run ./configure" Did you? What was the result? Welcome to Ask Ubuntu.
    – chili555
    Aug 1, 2020 at 1:19
  • @chili555 I ran ./configure and I have cc and gcc.
    – Aplleroar
    Aug 1, 2020 at 1:25
  • @steeldriver I will install the m4 package and see if it works.
    – Aplleroar
    Aug 1, 2020 at 1:28
  • 2
    @Aplleroar why are you trying to compile bison from source code? Do you want to learn something, what are the specifics? The bison is packaged in Ubuntu, so you can simply install it from precompiled deb-package to save time and prevent compilation issues...
    – N0rbert
    Aug 1, 2020 at 7:13

1 Answer 1

0

It seems that you are solving problems on source code level while all necessary development stuff is pre-compiled in deb-package form.

So you can install build tools by:

sudo apt-get install build-essential bison libbison-dev

Other development stuff may be found using search on https://packages.ubuntu.com - provide name of package and dev suffix to sort out the things. Next install the package by using APT - something like sudo apt-get install name-dev.

1
  • Thank you but build-essential does not contain gcc10.2 which was what I needed. I have installed m4 package and I can run make now.
    – Aplleroar
    Aug 5, 2020 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.