2

I just upgraded to 20.04 and the upgrade seemed to have gone fine, but when the computer rebooted after the upgrade it does nothing but sit at "Loading Linux 4.15.0-1019-oem . . .".

I had previously configured grub to force this kernel because of a a bug with my thunderbolt dock in the newer kernels. I've tried holding down shift to get into the grub boot menu and seeing if removing this option fixes the problem, but I can't get to the grub menu. No matter what I've tried the system just flashes the bios screen and then immediately gives me the above message.

Any suggestions of how I can get in to grub to remove that and/or other ways to solve the problem?

2
  • One suggestion is to follow the steps here to gain access to your installed system and then try to modify grub as you normally do.
    – Raffa
    Aug 1, 2020 at 1:32
  • Is this post-Boot-Hole fixes or pre-?
    – will
    Sep 1, 2020 at 7:28

2 Answers 2

2

For future people, I ended up taking inspiration from the other suggestions and did the following to recover the system:

  1. Created Ubuntu 20.04 live USB stick
  2. Boot system into it (for some reason for me Delete didn't work to get into BIOS like normal, but F12 did)
  3. Mount the internal hard drive (sudo fdisk -l to find what it's mounted as, sudo mkdir /media/internal, sudo mount /PATH/FROM/FDISK /media/internal
  4. Edit grub config to remove old invalid config (sudo nano /media/internal/etc/default/grub)
  5. Follow directions in this post to update grub config substituting /media/internal/ for /mnt.
  6. Reboot and it should work!
1

I've had similar problems in the past, for me the problem is usually that I don't get the Grub screen and it boots directly to the other operating system installed.

I'd say you try the easiest of all solutions and that is to make a rescue USB stick, I use "boot-repair-disk". Usually running this OS once from a usb stick, connecting online and letting it fix the problem has done it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .