0

I'm honestly in tears, I've just lost 60GB of music I've been collecting for over 15 years.

I mounted a drive to /mnt and moved all the music files over to it. When it finished I checked that the files were all there and then shut down my computer and rebooted it into Windows. The files were not there, shut down again and booted back into Linux and they've all vanished. I have no idea what to do. Have they actually been deleted?

Any help is hugely appreciated :(

  • Probably they're somewhere on your system, just not where you expect. More details, like was the target a separate disk? where exactly did you mount it, and what filesystem was on it? How did you copy, and how did you check that the files were at the target location? – ubfan1 Jul 31 at 16:02
  • You can try this diskinternals.com/uneraser/… – turbulence Jul 31 at 16:03
  • @ubfan1 They are separate disks. I mounted the disk to /mnt and moved the files into the new location using Caja (Ubuntu MATE File Explorer), then I restarted my system and they all disappeared. – Shaun Wild Jul 31 at 16:08
  • Did you re-mount the disk after restarting? mounts aren't persistent across reboots unless you add them to /etc/fstab – steeldriver Jul 31 at 16:12
  • Yea I've tried remounting the disk. There was a folder called "System Volume Information" which is still there. But the other folders have all gone. I've even downloaded testdisk and tried recovering any deleted files, they're all gone. – Shaun Wild Jul 31 at 16:13
0

If NTFS & RAW, you want to get to this screen:

https://www.cgsecurity.org/wiki/TestDisk_Step_By_Step#NTFS_Boot_sector_recovery

select [Advanced] instead of [Analyze] and select [BackupBS] [HowTo] Repair the bootsector of a Windows partition - YannBuntu

https://help.ubuntu.com/community/BootSectorFix

http://ubuntuforums.org/showthread.php?t=1926510

If files were written into partition, then Windows scan tools or photorec may work. Windows tools may be better as they can get full file name. Photorec only recovers by type with file extension. If photos you can often can rename with info from within the photo. You have to use another drive, the backup drive you should have already had?

http://www.cgsecurity.org/wiki/PhotoRec_Step_By_Step

| improve this answer | |
0

I solved the problem in the end by switching over to windows and running chkdsk, after it completed a few hours later all of my files reappeared.

| improve this answer | |
  • 1
    You can accept your own answer (maybe after a waiting period), so others know this has been solved. – ubfan1 Aug 2 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.