0

I am using Ubuntu 18.04.4 with Dual boot Windows 10 on a Lenovo machine and trying to use THESE instructions to install Droidcam. When I do the installation, I get an error which says:

insmod: ERROR: could not insert module /lib/modules/5.4.0-42-generic/kernel/drivers/media/video/v4l2loopback-dc.ko: Operation not permitted

warning: insmod failed

After that I tried to run the software via terminal but got the following error prompt:

error prompt

I think the error has something to do with the UEFI secure boot.

When I do lsmod | grep v4l2loopback_dc I don't get any output, indicating that Droidcam isn't really installed.

Can someone please help me with the installation?

0

So Droidcam is working now.

First, I uninstalled Droidcam.

Second, Using the answer by Earl Sablo I tried the following:

sudo update-secureboot-policy --enroll-key

It asked to create a password for the secure boot menu, which I created.

Then I restarted my PC and the secure boot menu asked threw a number of options. Choose "Enter MOK key", and use the password created earlier.

Finally, reboot and reinstall Droidcam. It works fine now.

3
  • Did you installed via ./install or ./install-dkms? I tried both and didn't work – euDennis Sep 8 '20 at 17:43
  • ./install Check this -- dev47apps.com/droidcam/linux What error are you getting? – Shihab Khan Sep 9 '20 at 18:36
  • I was able to do it now, but I have to install using ./install-dkms and after that, the ./install worked – euDennis Sep 29 '20 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.