I'm using Windows 10 and trying to install Ubuntu 20.04 on my laptop using a bootable USB drive.

I received this error message before the loading page shows up: "Failure creating named object" with some firmware bug.

Screenshot here

It always forces a shutdown after the loading reaches 3%.

Screenshot here

I tried updating my BIOS to the latest version.

  • What model Asus? You need either safe graphics boot or nomodeset boot parameter if nVidia graphics. Should be similar as vendors often use same UEFI:. Acer Aspire 5 Model A515-54-5649 Intel Core i5-10210U Install Tutorial ubuntuforums.org/showthread.php?t=2437702 – oldfred Jul 31 '20 at 15:34

I have solved the problem by setting nouveau.modeset = 0 before install and then install nvidia driver after the installation process is done.

Here’s link to the tutorial: https://medium.com/@nitinpatel_20236/fixing-the-problems-installing-ubuntu-on-asus-rog-laptop-asus-gl503ge-5b6f497201b8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.