0

Getting [FAILED] - Failed to start NVidia Persistence Daemon. And the screen went black with the cursor blinking in 20.04.

My videos were getting stuck and not playing properly in the VLC. So, I tried to update the Nvidia driver. I went to the Additional Drivers tab, it had "using (proprietory, tested) selected by default, but I selected the second option which was having just (proprietory) and clicked apply changes. I got the dialog box to give a secure boot password and I gave it. Upon restart, I got a small blue box with options "Continue to boot", Open MDK, and one more option. I chose "Continue to boot". And the system started to boot but got stuck with a cursor blinking in black screen. It's not successfully booting. I searched this forum and as suggested in other posts, tried to disable the Secure boot option and restarted again. This time, I pressed Ctl + Alt + F1 and I could see the statuses. In that I saw the message [FAILED] - Failed to start NVidia Persistence Daemon. And the screen went black with the cursor blinking.

I don't get the GRUB screen to go to the terminal mode to uninstall or update the driver. How can I fix it? Please suggest.

0

I was able to fix using the below steps:

While booting, keep pressing the ESC key after the manufacturer logo and before the Ubuntu logo appears.

The GRUB Menu should appear. But for me I got the Grub command line instead. like:

grub>

Type 'normal' and hit enter. And keep pressing ESc again. Will get the GRUB menu now.

Choose the line that starts with "Advance Options:" and hit enter. You will get a Recovery Menu box: Choose the option = root - Drop to root shell prompt.

You will get the root command prompt at the bottom of the screen. Type the below commands to fix it. i.e to uninstall/remove the Nvidia proprietory drivers and install the default drivers.

-- sudo ubuntu-drivers list < To see the list of drivers >

-- sudo apt-get remove --purge '^nvidia-.*'

-- sudo apt-get install ubuntu-desktop

type 'reboot' to restart the system.

The Ubuntu was rebooting again as usual.

Hope this helps someone!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.