12

I just installed 12.04 (fresh install) and realized I could no longer tether with my iPhone like how I did on 11.10 without any hassle. On 11.10 (to my amazement) all I had to do was turn on USB tethering option in MyWi and my system would automatically connect to the Internet via my phone. What has changed and how can I tether again?

BTW it is an iPhone 3G (jailbroken)

3 Answers 3

8

To get iPhone USB tethering working again, just install the following packages:

  1. ipheth-utils.

  2. libimobiledevice-dev

  3. libimobiledevice-utils

You can install these packages through apt-get command or through the synaptic package manager sudo apt-get install synaptic

2
  • What's the best way to do this when you don't have any alternative for an internet connection but your actual phone? I mean, I could get off my ass and go into the coffee shop but... Commented Jul 6, 2015 at 0:09
  • @boulder_ruby – The best way would be to use your device's wifi tethering to install the necessary software before switching to USB. On an iPhone, that's (currently) Settings → Personal Hotspot, which is near the top, not far below Wi-Fi.
    – Adam Katz
    Commented Jul 21, 2017 at 14:05
7

On top of the steps listed by Mysterio, you may need to use the following command in a terminal window to get it working:

idevicepair unpair && idevicepair pair

Then unplug your phone and plug it back in. When you plug it back in, a notification should pop up (on your Ubuntu system) saying it has connected to a wired network. (If the notification does not appear, make sure Personal Hotspot is enabled on your phone.)

This works for me with a non-jailbroken iPhone running iOS 5.0 and no additional software on either my laptop or phone.

4
  • This doesn’t work with iPhone 7s and Ubuntu 16.04. All I get is an attempt to connect followed by a pop up warning saying “Ethernet disconnected”
    – Paul
    Commented Jan 4, 2018 at 1:04
  • I get No device found, is it plugged in?
    – explorer
    Commented Sep 9, 2018 at 13:37
  • It worked for me (Ubuntu 14.04). Without this didn't work.
    – lepe
    Commented Nov 27, 2018 at 9:00
  • I got SUCCESS: Unpaired with device. SUCCESS: Unpaired with device because a passcode is set. Please enter the passcode on the device and retry. How to mention passcode which is set in my case on my hotspot.
    – HalfWebDev
    Commented Nov 14, 2020 at 16:35
2

Installing the usbmuxd package solved the issue with iphone 7 and 17.10.

2
  • Only answer that worked for me. Thanks :D Commented Jul 11, 2020 at 12:49
  • @TheTechRobo36414519 Did you restart your machine to get it working?
    – HalfWebDev
    Commented Nov 14, 2020 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .