9

I just installed 12.04 (fresh install) and realized I could no longer tether with my iPhone like how I did on 11.10 without any hassle. On 11.10 (to my amazement) all I had to do was turn on USB tethering option in MyWi and my system would automatically connect to the Internet via my phone. What has changed and how can I tether again?

BTW it is an iPhone 3G (jailbroken)

6

To get iPhone USB tethering working again, just install the following packages:

  1. ipheth-utils.

  2. libimobiledevice-dev

  3. libimobiledevice-utils

You can install these packages through apt-get command or through the synaptic package manager sudo apt-get install synaptic

  • What's the best way to do this when you don't have any alternative for an internet connection but your actual phone? I mean, I could get off my ass and go into the coffee shop but... – boulder_ruby Jul 6 '15 at 0:09
  • @boulder_ruby – The best way would be to use your device's wifi tethering to install the necessary software before switching to USB. On an iPhone, that's (currently) Settings → Personal Hotspot, which is near the top, not far below Wi-Fi. – Adam Katz Jul 21 '17 at 14:05
6

On top of the steps listed by Mysterio, you may need to use the following command in a terminal window to get it working:

idevicepair unpair && idevicepair pair

Then unplug your phone and plug it back in. When you plug it back in, a notification should pop up (on your Ubuntu system) saying it has connected to a wired network. (If the notification does not appear, make sure Personal Hotspot is enabled on your phone.)

This works for me with a non-jailbroken iPhone running iOS 5.0 and no additional software on either my laptop or phone.

  • This doesn’t work with iPhone 7s and Ubuntu 16.04. All I get is an attempt to connect followed by a pop up warning saying “Ethernet disconnected” – Paul Jan 4 '18 at 1:04
  • I get No device found, is it plugged in? – explorer Sep 9 '18 at 13:37
  • It worked for me (Ubuntu 14.04). Without this didn't work. – lepe Nov 27 '18 at 9:00
1

Installing the usbmuxd package solved the issue with iphone 7 and 17.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.