2

I am unable to boot using Live CD (USB) install for 20.04 LTS.

System Configuration:

Intel NUC10i3FNH Gigabyte m.2 2280 SSD 256GB 1 x 16GB HyperX SODIMM 2666MHz

Screenshot below

Bootscreen

Any ideas what to do?

/Uffe

8
  • Hi Uffe, might be worth seeing if Ubuntu 18.04 boots okay from a Live USB, just to see if the NUC is having difficulty specifically with 20.04 or if it's not happy about booting Live USB's in general.
    – pHeLiOn
    Jul 30 '20 at 18:24
  • I have tested 18.04 - unfortunately same result...
    – uffe s
    Jul 30 '20 at 18:44
  • I've had a look for NUC related issues and found something similar here: askubuntu.com/questions/1208115/… and a comment by @ubfan1 pointed towards a suggestion here: askubuntu.com/questions/1178285/… about going into the BIOS settings and checking the TPM or Intel Platform Trust Technology setting in the Security section of the UEFI/BIOS. Someone disabled it to get it to work and another said they had to enable it, so might be worth changing it to see if it helps
    – pHeLiOn
    Jul 31 '20 at 2:02
  • Yep, I have read those threads and tried the actions accordingly - without success.
    – uffe s
    Jul 31 '20 at 7:10
  • The NUC 9 series is officially supported but the Intel NUC 10i3FNH might not yet be. A common issue that's worth checking: 1. Try your Ubuntu 20.04 Live USB in another computer. This confirms that there isn't a problem just with your Live USB. Update your question with this info. ('Live USB works fine on my laptop/desktop') 2. Update your question with the info about the TPM - ('Checked TPM in BIOS - TPM was disabled/enabled - changed it to ? - still can't boot Live USB') This information will be helpful and easily visible for anyone looking at your question.
    – pHeLiOn
    Jul 31 '20 at 13:58
0

I strongly suspect your USB hardware — the flash drive or any hubs you may be using — to be the culprit. I have successfully installed Ubuntu 20.04 LTS (server version) with no issue on an Intel NUC10i3FNH with an m.2 SSD (Western Digital in my case). Those USB errors indicate that something isn't communicating properly between the OS and the USB hardware; I've seen them before on NUC 7's, and it's indicative of a failing USB device or port.

  1. Make sure you're plugging the USB drive directly into the NUC's built-in USB ports — no hubs, cables, et cetera; this includes Type C-to-A adapters (or vice versa)
  2. I've noticed that USB ports on the NUCs tend to be very snug, so make sure your drive is inserted fully (turn off the NUC, remove the drive, reinsert firmly, try again)
  3. Try the USB drive in another port. The NUC10s have three USB type A and two type C ports, so you definitely have a choice no matter what sort of drive you're using (please tell me you're not using the SD card slot? LOL)
  4. Try a different flash drive. Even if you only have one fast flash drive and the rest are slow, try a slow one just to see if it works successfully. Also, if your flash drive is USB 2.0, try a USB 3.0 drive if possible, and vice versa.

The company I work for has deployed literally thousands of NUC 7 devices across the United States and India, and we are working on upgrading to NUC 10s... so I've had lots of hands-on experience with this hardware and all its quirks and foibles (much to Intel's dismay, because I harass them about it 😅).

0

I finally got my NUC10i7FNH operational with Ubuntu 20.04. I disabled lots of stuff in the BIOS (Bluetooth/Wi-Fi, HDMI TV controls), but the big one that finally worked was turning off Intel Turbo Boost Technology on the PerformanceProcessor page.

I went back later and started enabling all the items I had recently disabled. The boot failed, so there is a combination of settings that worked. My changes were all on the Advanced tab in the BIOS, and the one checkbox on the Processor page.

BIOS settings

2
  • Please, could you share images of the other bios tabs also!? I have the same NUC and intend to install Ubuntu 20.04, so that would be very helpful. Thank you
    – PerlTomas
    Feb 19 at 10:58
  • I'm also having trouble with the NUC10i7FNHJA and Ubuntu 20.04 LTS Server. Unfortunately, disabling Intel Turbo Boost did not do the trick for me. Were you able to isolate any other settings that helped you get through the install process? May 22 at 22:15
0

It looks like the actual solution to this problem is to switch from RST to AHCI in the BIOS Storage settings.

I found this out by attempting to install Ubuntu 21.04 Desktop edition. The graphical installer popped a warning and directed me to this page that explains the issue.

Once I made that BIOS change, the 20.04 LTS Server installer worked as expected.

FWIW, I have a NUC10i7FNHJA and previously upgraded the BIOS and firmware.

0

I also had a lot of problems running Ubuntu 20.04 TLS, I bought NUC10FNK, the problems I had was related to the disk, type M2, I installed several times, with different USBs and different files, each time different errors, mainly had a read-only filesystem error...

This is the configuration in which it worked for me in the end:

Changes I made to the BIOS:

I turned off all the features I did not need such as - Bluetooth, HDMI CEC ...

In STORAGE I turned off the SMART SELF TEST and after installing the OS, I changed the SATA MODE from AHCI to RAID ...

In the process of installing the UBUNTU:

I chose a minimal installation, deleted the disk, and did the installation without internet connections...

Now it seems to be working...

The STORAGE settings in the BIOS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.