i've got epson sx130 all in one printer. everything was working correctly on ubuntu 10.10. I upgraded to 12.04 recently and system recognize just the printer now. simple scan shows me yellow bar with message "no scanners were detected" or something like that. is there any solution to fix it? i cannot find anything in google. thanks


Try with this drive - Download Scanner Driver core package&data package

install this file iscan-data_1.17.0-2_all.deb followed by this iscan_2.29.1-5~usb0.1.ltdl7_i386.deb

| improve this answer | |
  • 1
    it started to work for my sx130 after I installed latest binaries: iscan-data_1.22.0-1_all.deb, iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb – Ruslan May 2 '13 at 14:26

Have you tried installing the drivers from the Espon site?

You should be able to download the drivers in .deb format and install them. This worked for me with a different Epson scanner.

| improve this answer | |

Is SANE installed in your system? Try this tuto.

| improve this answer | |

I was finally able to put my scan Epson sx130 working, with my clean installation of Ubuntu 13.10. I downloaded the drivers from Epson website that someone specially past in "Ubuntu channel" for me, because on search engine I wasn't able to find it in first places of google searchs, with this pal tip, I was able to find 2 drivers iscan-data_1.24.0-2_all.deb to install in first place using the command in terminal :

cd Transferências

this was my diretory, in your case you type:

 cd your directory

then I typed on terminal (to open terminal windows Ctrl+Alt+T):

sudo dpkg -i data_1.24.0-2_all.deb

it said to me to install "xsltpro" because with out it couldn't install the drive.

so I went to Ubuntu central software and typed "xsltpro" and clicked install it!

then I typed again on terminal :

sudo dpkg -i data_1.24.0-2_all.deb

this installed it.

Then I typed on terminal:

sudo dpkg -i iscan_2.29.2-1~usb0.1.ltdl7_i386.deb

this install it also!

Another pal in Ubuntu IRC channel, told me to install "xsane" and I did it, typing "xsane" on Ubuntu software center, and clicking install it.

Then I typed on terminal:

sudo apt-get update
sudo reboot

And, VOilááááá! Thanks to you all and your help the scan started to work fine. I forgot to mention that I already have been installed the printer, using System Settings, on graphic mode, so the only thing that wasn't working was the scanner, because Epson sx130 is an all in one device! But now it works wonderfully!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.