2

The Issue

I recently updated from 18.04 (with running nvidia drivers) to 20.04. Now, after installing the nvidia drivers I get a black screen after selecting Ubuntu in the GRUB menu. At the top of the screen it is written in console style

/dev/nvme0n1p7: clean, 1479251/17219584 files, 57208401/68869632 blocks

What I tried

I tried different versions of installation like

  • sudo ubuntu-drivers autoinstall
  • sudo apt install nvidia-driver-440
  • sudo apt install nvidia-driver-390
  • using the Software&Updates -> Additional Drivers GUI
  • launch Ubuntu from bootable USB and try boot-repair

All resulted in the same behaviour / didn't help.

To revert the changes I can do Ctrl+Shift+F6 which gives me a prompt, login with username and passwort and do

sudo dpkg -P $(dpkg -l | grep nvidia-driver | awk '{print $2}')
sudo apt autoremove
reboot

which gives me a proper login screen again - without nvidia drivers obviously.

My System

ubuntu-drivers devices yields

vendor   : NVIDIA Corporation
model    : GM107M [GeForce GTX 960M] (XPS 15 9550)
driver   : nvidia-driver-435 - distro non-free
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-440 - distro non-free recommended
driver   : nvidia-driver-440-server - distro non-free
driver   : nvidia-driver-418-server - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

I run Ubuntu 20.04 / Windows 10 dual boot.

2

Sort of a Solution

Rather than relying on the system which I got from doing an upgrade from Ubuntu 18.04 to 20.04, I did a complete fresh re-install of Ubuntu 20.04 and now everything seems to work. I did update the drivers via "Software&Updates" in the Additional Drivers tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.