2

I am using Ubuntu 18.04, and I want to install Unity 2019.4.2f which my team uses.

But I can't find the older version, but only the latest version 2019.4.5f1(LTS) on the install page of Unity Hub. enter image description here

The Unity Hub installation link in Unity Archive website is also not working. And I can't find the installion file for Linux.

1 Answer 1

1

Older versions can be found on Unity's website: https://unity3d.com/get-unity/download/archive. Once you click the download link, it will prompt you to install on your Unity Hub.

What do you mean by the unity archive not working?

1
  • 1
    It does not prompt the installation when clicking the download link. It seems that the link to Hub is broken in my environment.
    – dolgom
    Feb 3, 2022 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.