1

I'm trying to open .pdf files in Firefox with acrordrdc installed via snap. I tried:

  1. Since acrordrdc file.pdf works I tried using a "wrapper" file:

    #!/bin/bash
    acrordrdc $1
    
  2. Editing the acrordrdc.desktop (see Changing default app for PDF).

In the first case (the wrapper solution) acrordrdc opens with an empty window. No file is showed.

In the second case I can select "Acrobat Reader DC" in Firefox but nothing happens when the files is downloaded. Acrobat is not opened.

Edit. After the N0rbert answer I tried to modify my wrapper:

#!/bin/bash
cp $i ~/Downloads/renamed.pdf
acrordrdc ~/Downloads/renamed.pdf

and now it works. Now I need to find a way to remove the file(s) after I read it (them).

I don't understand why I need to rename it. If I have:

#!/bin/bash
cp $i ~/Downloads/$1
acrordrdc ~/Downloads/$1

it doesn't work. The file is copied but not opened.

6
  • The acrordrdc snap is Wine-based. So there may exist some specifics with file-associations. Did you tried to open the PDF file from file-manager by right click on it and selecting Open WithAdobe Acrobat Reader DC ? Is it working normally? – N0rbert Jul 29 '20 at 16:15
  • @N0rbert I just tried. It works normally. – Gabriele Nicolardi Jul 29 '20 at 17:05
  • What is your Ubuntu version and desktop? – N0rbert Jul 29 '20 at 17:44
  • Ubuntu 20.04 with Mate. I installed Ubuntu Classic + ubuntu-mate-desktop – Gabriele Nicolardi Jul 29 '20 at 17:53
  • I tried to prepare the answer on Ubuntu MATE 16.04 LTS, but acrordrdc acts weird here. I'll check the Ubuntu MATE 20.04 LTS and report results. – N0rbert Jul 29 '20 at 17:55
1

After some debugging in Ubuntu MATE 20.04 LTS I discovered that Firefox copies PDF file of interest to the /tmp folder.

The /tmp folder can't be accessed by this snapped application. Wrapper script does not help either. So it is impossible to integrate /snap/bin/acrordrdc with Firefox.

I'll recommend to remove snapped version of Adobe Acrobat with

snap remove acrordrdc

and install native pretty old deb-based version of Adobe Reader 9.5.5 by:

cd ~/Downloads
wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install ./AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install libxml2:i386 gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386 libcanberra-gtk-module:i386 libatk-bridge2.0-0:i386 libatk-adaptor:i386

and then choose it in the Firefox settings.

3
  • I edited my question after you answer. Unfortunatly I need a more updated version of acrobat reader. Installing AR 9.5.5 is not a solution. – Gabriele Nicolardi Jul 29 '20 at 21:48
  • I think snap connect acrordrdc:removable-media should also work. – Kulfy Jul 30 '20 at 11:58
  • @Kulfy, no - it does not work. – N0rbert Jul 30 '20 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.