This seems a very simple problem but it's driving me nuts. I'm trying to mount two ext4 partitions at boot time with /etc/fstab.(They are written differently because I read in a forum that there were some problems mounting by uuid)

Here are the two lines:

UUID=c7fa17c3-e1e0-489e-93ec-341928069664 /home/alice/VirtualGarden ext4 rw,suid,dev,exec,auto,user,async 0 2

/dev/sda8 /home/alice/Saco  ext4 rw,suid,dev,exec,auto,user,async 0 3

The main problem is that after boot I won't have access to either partition. They appear in my desktop, but when I try to list their content they are empty. Everything works if I mount them as a normal user after boot. For example:

mount /home/alice/Saco

I don't know if this makes a difference, but the mount point (/home/alice/) is an encrypted partition. I tried to move the mount point to /Saco and it mounted perfectly after reboot.

Another thing is that if I use the UUID in fstab Nautilus creates two links for the same partition. I did some research and I have solved this by using /dev/disk/by-uuid/.

Any tips or advise are welcome.


Your encrypted partition doesn't get mounted unless you provide the password, while the system tries to mount the other partitions before that happens.

The obvious advise: mount your partitions somewhere else (eg., /media/alice/... or /mnt/alice/...). You can place a symlink to those mount points, if you absolutely want them to be accessible from /home/alice/...:

ln -s /media/alice/VirtualGarden /home/alice/VirtualGarden
ln -s /media/alice/Saco /home/alice/Saco

Why do you use the manual way if you are unclear,install ntfs-config to automount partitions.I have been using this in 10.04 for few months.It is good,just try it.


sudo apt-get install ntfs-config

Also see this post

  • Thank you for the advice. I might try it later, but I'm trying to learn how to do as much as possible through the command line... – alxlenc Nov 11 '10 at 16:13

It seems that your encrypted partition is mounted after the system has tried to mount /home/alice/Saco. As there is no /home/alice at the time system try to mount /home/alice/Saco, then this partition is not mounted but is available to be mounted manually after the system has been booted up. Would you provide information about when you mount your /home/alice encrypted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.