I was doing upgrade from 11.10 to 12.04, It showed some error. Then I restarted the system. Now it's not booting. It's showing the following error when it starts and reboot by itself.

sed: /lib/x86-64-linux-gnu/libc.so.6:version 'GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libselinux.so.1)

please please reply back with some solutions. I am kind of stuck not able to use the system. I need it so badly.


I had this problem and solved it.

Here is the link to my answer on another same question:


  • Hey thanks a lot. your solution worked as it seems. :) – Vipul Gupta Apr 27 '12 at 23:29

You can try the answer that Andrew gave here : https://askubuntu.com/a/126282/56942. You will need the live cd or live usb.

  • Hey I tried but still I am getting the same error almost. but with different required directory sudo: /lib/x86_64-linux-gnu/libc.so.6: version 'GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu//libpam.so.0 Please help with this issue if you can.. I am kind of stuck... I am kind of naive to ubuntu. – Vipul Gupta Apr 27 '12 at 21:31
  • if you type in a terminal uname -a can you paste the output? I think you have the wrong version maybe have a 32 bit version and trying to install the 64 bit – Brett Apr 27 '12 at 22:15
  • I am installing the right version. I have 64-bit and I am installing 64-bit only. – Vipul Gupta Apr 27 '12 at 22:48
  • pzanoni has given a detailed solution of it and it worked as it seems right now. askubuntu.com/a/126542/56649 – Vipul Gupta Apr 27 '12 at 23:52

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.