3

I am using Ubuntu 18.04 with GNOME Classic. With GNOME Classic I use window list, this shows me all my currently open apps:

GNOME Classic with window list

When I open a file in GIMP, the icon in the window list changes and appear an icon related with the image appears.

GIMP icon in window list before opening an image:
GIMP icon in window list before opening an image

GIMP icon in window list after opening an image:
GIMP icon in window list after opening an image

Is there a way to disable this behavior?

I want to keep the GIMP icon always.

For example, for Firefox, OpenOffice, Chrome the icons never change. It always shot the program icon, not an icon representing the page or document open.

0

I fixed this by finding .desktop file for Gimp find / | grep gimp.desktop and adding new line with StartupWMClass=Gimp-2.10. But this solution is version-specific and needs to be updated with each new version release.

You can find your Gimp's WMClass with xprop WM_CLASS command and clickling into Gimp window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.