I have a Mac OS X and VMware Fusion. I did a fresh install of 12.04. I do not have VMware Tools installed.

I read that I do not have to log in at the command window, that I have to wait for VMware Tools to get installed. It seems like something is wrong.

  • "Vmware Easy Install PLEASE WAIT! VMware Tools is currently being installed on your system. Depending on the version of Ubuntu you are installing, you may log in below and use the system during intallation. Otherwise, please wait for the graphical environment to launch. Thank you." Feb 19, 2013 at 20:01
  • This link might help. Jul 5, 2014 at 18:14

6 Answers 6


I don't know exactly why it fails, but there are three things you need to get things back to normal.

  1. Restore the /etc/issue file:

    sudo mv /etc/issue.backup /etc/issue

  2. Restore the /etc/rc.local file:

    sudo mv /etc/rc.local.backup /etc/rc.local

  3. Restore the /etc/init/lightdm.conf file:

    sudo mv /opt/vmware-tools-installer/lightdm.conf /etc/init

Then reboot (sudo reboot) or run sudo start lightdm to see the greeter.

  • 1
    Then I had to do this to reinstall the tools : kb.vmware.com/selfservice/microsites/…
    – Eric
    Jun 15, 2012 at 15:37
  • This is what worked for me, and i also followed Eric's link and did those steps.. Im running vmware 4.1.1 with OS X 10.7 as guest, and ubuntu 12.04LTE x32 as host (fresh install).
    – Manco1911
    Jun 22, 2012 at 0:50
  • following the steps 1-3 worked fine for me! thanks so much!
    – stantonk
    Sep 3, 2012 at 1:16
  • If these steps aren't clear, you can see them performed on video here: youtube.com/watch?v=fmyRbxYyOmU Aug 22, 2014 at 0:21

I've used the following method before and it works:

  1. Login at the prompt.
  2. Enter this command to install GDM:

    sudo apt-get install gdm
  3. Enter your password and install.
  4. Reboot
  5. Login at GDM.
  6. Install VMware Tools.

For me the solution has been removing the images mounted in the floppy drive and the DVD drive that make the easy install start automatically. The system boots and then you have to set a password for the root user and use that to login.

Then you install the VMware tools manually and everything works as expected, finally!


I got past this screen by pressing: Alt+Left arrow (twice).


Log in at the prompt and type startx, then hit Enter.

  • This is the easiest way to solve this problem; thanks!
    – Mr. Handy
    Mar 7, 2016 at 13:48

Since this is basically a messed up install, one approach would be to restart the install from scratch -- this time without VMware's "help".

Set the CD/DVD to point to the installation ISO and hit 'esc' when the BIOS screen appears so that you can tell it to boot from the ISO instead of the existing broken installation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .