its a fresh 12.04 install 64bits. wifi works fine, wired stays off with cable connected and network-manager shows as if cable is disconnected. Turning off networking lights up my network-cards leds, turning networking on shuts off the leds and no communication is possible.

I already tried, turning off the network-manager (sudo service network-manager stop) and setting up my eth0 manually, as soon as I switch off the network-manager my leds light up, but after setting up manually eth0 (sudo ifconfig eth0 netmask up) the leds turn off again. I am still dual booting with 10.04 where I have no issues at all, leaving the cable connected all time to my notebook and a switch.

Here is some hardware info: lshw:

            description: Ethernet interface
            product: RTL8111/8168B PCI Express Gigabit Ethernet controller
            vendor: Realtek Semiconductor Co., Ltd.
            physical id: 0
            bus info: pci@0000:03:00.0
            logical name: eth0
            version: 03
            serial: c8:0a:a9:d7:05:97
            size: 10Mbit/s
            capacity: 1Gbit/s
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
            configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
            resources: irq:42 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff memory:f0010000-f001ffff


    02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

ifconfig eth0:

eth0      Link encap:Ethernet  HWaddr c8:0a:a9:d7:05:97  
      inet addr:  Bcast:  Mask:
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:42 Base address:0xc000 

cat /etc/network/interfaces: (already tried here with and w/o eth0)

auto lo eth0
iface lo inet loopback

cat /etc/NetworkManager/NetworkManager.conf



Any help is welcome ;) Laket

8 Answers 8


Reaktek: http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

  • 4
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – fossfreedom
    Jul 26, 2012 at 15:57
  • Apparently many people are facing the similar problem with r8169 driver. This driver r8168 works like a charm
    – akashrajkn
    Nov 9, 2015 at 16:46

I had the same problem. I solved it by adding (the graphical way) a new network connection, that automatically connects with "Automatic DHCP" as the setting. It seems that this default had been removed?!


Update - My issue was unrelated to the orginal author's. The instructions I provided below disabled Network Manager. This circumvents dnsmasq, which had been inaccessable due to iptables blocking localhost-to-localhost UDP traffic.

Is this a DNS issue? Can you ping but get nothing from host google.com?

Edit /etc/network/interfaces to look like:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp


$ sudo ifdown eth0
$ sudo ifup eth0

This happened to me after upgrading from 11.10 to 12.04. For some reason that last line of the interfaces file had been commented out.

  • thanks JohnNKing, I don't really know what it was, was not an dns issue since the interface was going down on the up request and on up was going down. I didn't see any updates but after restarting my notebook 10 times, the interface is working again.
    – laket
    Apr 27, 2012 at 18:50
  • Opps, sorry; I think I misread the question. I'm glad it's working for you now.
    – John King
    Apr 30, 2012 at 13:37
  • Any chance this was a driver issue? There are some similarities with: superuser.com/questions/290822/…
    – John King
    Apr 30, 2012 at 13:57

I solved this problem with a little of magic :)

r8169 seems not to work if it's eth0...but it works if it's eth1 (don't ask me why...don't know)

So you have to edit /etc/udev/rules.d/70-persistent-net.rules file. You'll find something like this:

PCI device 0x8086:/sys/devices/pci0000:00/0000:00:19.0 (e1000e) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1c:c0:af:60:c5", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

let's change last character in ATTR(address) content (e.g.: :c5" becomes :c6":

PCI device 0x8086:/sys/devices/pci0000:00/0000:00:19.0 (e1000e) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1c:c0:af:60:c6", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

Now reboot your computer, when system comes up, your net card will be eth1 :)

  • This worked for me except I just changed the name from eth0 to eth1. Weird. Feb 8, 2014 at 20:43
  • My address ends with e1. Does it become e2? @DanaBenson This didn't work for me.
    – GisMofx
    Oct 1, 2016 at 5:39

I have an ASUS motherboard with 8111/8168B (rev06) and had similar issues. By following this blog post my wired connection is now consistent and best of all fast. Should you install a new kernel version you should do the install of the module after booting into the new kernel. The package with driver is available on the Realtek website and has an auto install shell script however i have found it far easier and reliable to simply copy/paste the commands into a terminal. I hope you have similar success, good luck!


Sorry for my English (translated with google) Here is the latest realtek driver from the month of May to compile:


  • 1
    Since that file could be anything, do you have a link to the driver on the Realtek website? (Or is it no longer available?) I'm not asking you to remove this link, but if you could also provide more information about where you got it, I think that might be helpful. Jul 18, 2012 at 22:30

I have been fighting this problem for quite some time and have seen it blamed on the R8169 module through several distributions of Ubuntu and others.

I found a suggestion (but can't remember where) to switch to wicd for a network manager.
There are many versions of Ubuntu and derivatives that won't allow removal of the network-manager and network-manager-gnome as it seems to be part of the desktop base.

I have found some Debian distros that will allow it such as Bodhi and Debian XFCE. When I switch the OS to use wicd the wired connection problem with rtl8111/r8168 disappears.

A check of lsmod shows that the r8169 module is loaded. As a result of this experiment I believe that the problem lies within network-manager and not the module. I could be wrong and often am, but the experiment is easy enough to try.


Try this command and see if it works

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .