It would appear it's impossible to get virtualbox guest additions working in a windows 7 host running vbox 4.1.14 and an ubuntu 12.04 32-bit guest.

I've tried the standard .iso, the .run file, and the official ubuntu virtualbox-ose-guest packages.. none of them allow me to turn on seamless mode or use copy/paste.

Any help would be much appreciated!

  • Have you tried Oracle Virtualbox instead of open source Virtualbox? Apr 27, 2012 at 15:24
  • 1
    Did you do it as outlined in this answer? The repository guest additions will not work in the latest Oracle release 4.1.14.
    – Takkat
    Apr 27, 2012 at 15:34
  • Thanks, Takkat - the key was the "Places" comment. When I used the "install virtualbox guest additions" menu item, I was getting an error, so I assumed I couldn't mount the CD anymore, thus I tried a direct download of the .run file from download.virtualbox.org/virtualbox/4.1.14 , which didn't work. Once the CD mounted properly, I was able to run the .run package contained on it successfully. Thanks!
    – tamale
    Apr 27, 2012 at 19:56

1 Answer 1


This works for me - with reservations! I obeyed all the standard instructions from the documentation (update, upgrade, install dkms, reboot, then install Guest Additions and reboot again).

The problems start in Full Screen or Seamless mode where it appears the the screen refresh is broken - for example you get up a Terminal and start typing - nothing happens. Click OUTSIDE the terminal and all your typing magically appears. Reverting to windowed mode fixes this and the system works including cut and paste between Windows and Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.