I just distro upgraded to 12.04. I hoped that this time I won't have to suffer a whole night to get everything working, but my hopes were shot down quite quickly.

The UI in 12.04 is seriously broken, and I don't know why. The Unity animations are slow or not there at all. The Launcher reacts only like every third time I try to get it to show (I have it on auto-hide). Neither the application switcher (alt-tab) nor the workspace switcher look as they should. I can't take a screenshot of either. The app switcher only looks bad (like a Win98 default skin), it works. The workspace switcher (Expo) doesn't really. It opens without animation, and all the windows are displayed on the workspace in a grid, not just the top one. They can't be moved either. It also seems to ignore my settings that there should be 2*3 (total 6) workspaces, and only displays 5.

I get the feeling that this is due to some config clash from the upgrade. Is there any way I can fix it? If there's a way to nuke all settings or the whole gui and reinstall it clean and clear, I'm fine with that too.

  • 1
    Removing things in ~/.gconf/apps is often a good place to start for clearing config - e.g. the compiz-related things in there. Or you can just drop the whole folder, but that would remove things you may not want to lose. Commented Apr 27, 2012 at 15:12
  • If I delete that, will it be regenerated on restart? I wouldn't like to end up with a totally non-functional GUI.
    – Blackie
    Commented Apr 27, 2012 at 15:16
  • @Blackie - this is the community accepted way to clean up your config - please give it a try and let us know the results: askubuntu.com/questions/56313/…
    – fossfreedom
    Commented Apr 27, 2012 at 15:32

2 Answers 2


Open terminal and then type unity --reset in terminal. And then check the GUI and then revert us.

  • Yeah, that did it. It wasn't that simple though: I needed to install my GPU's proprietary drivers, and even then it took a few runs and reboots to get it all working. Now it's back to normal, except for the flickering bug mentioned in other places already.
    – Blackie
    Commented Apr 27, 2012 at 17:05

For those like me who aren't able to solve this problem with the answers already provided, I have an answer that worked. But, first let me mention something that didn't work. I took the extreme step of logging into the full screen terminal, Ctrl-Alt-F1 so that I could safely completely purge Unity and the Ubuntu desktop, and then re-install it and reboot. Nothing improved after that. Another answer that didn't work was to do a clean install of 11.10 and then immediately upgrade to 12.04.

The final solution for me that worked perfectly was to do a clean install of 11.10, install all the updates and extra applications I wanted, activate the proprietary NVIDIA accelerated graphics driver, get my desktop working just the way I wanted it to, make the proprietary accelerated graphics driver inactive again, and then upgrade to 12.04.

By the way, once you've got the screen looking and working just right with the proprietary accelerated graphics driver, all the settings will continue to work even after making that driver inactive. At least that's how it is on my system. The added advantage is that the flickering goes away. In 11.10, there was no flickering or poor quality fonts when the proprietary driver was active, but those are currently problems in 12.04, so just make it inactive and everything will be great.

Also, if you don't like how hard it is to get the Unity launcher to activate while in autohide in 12.04, you can fix that too. Just go to System Settings and click on Appearance. Now the Appearance dialogue includes a Behavior tab at the top which lets you increase or decrease the launcher sensitivity to moving the mouse pointer to the hot spot. Even better, you can move the hot spot back to the top left corner so you can make it highly sensitive without having it get in the way every time you need to click on something on the left side of the screen.

I hope my answer to question asked here, that worked for me, will help someone else as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .